PAT A 1037 Magic Coupon

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 10^5^, and it is guaranteed that all the numbers will not exceed 2^30^.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

扫描二维码关注公众号,回复: 2184505 查看本文章

还是理解题目,数学分析比码代码要难啊。。。想出思路一点也不难啊。。

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 100010;
int c[maxn];
int p[maxn];
int main() {
    int Nc, Np;
    scanf("%d", &Nc);
    int i, j;
    for ( i = 0; i < Nc; i++) {
        scanf("%d", &c[i]);
    }
    scanf("%d", &Np);
    for ( i = 0; i < Np; i++) {
        scanf("%d", &p[i]);
    }
    sort(c, c + Nc);
    sort(p, p + Np);
    int ans = 0;
    i = 0;
    while (i < Nc&&i < Np&&c[i] < 0 && p[i] < 0) {
        ans += c[i] * p[i];
        i++;
    }
    i = Nc - 1, j = Np - 1;
    while (i >= 0 && j >= 0 && c[i] > 0 && p[j] > 0) {
        ans += c[i] * p[j];
        i--, j--;
    }
    printf("%d\n", ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/joah_ge/article/details/80699147