【笨方法学PAT】1037 Magic Coupon (25 分)

版权声明:欢迎转载,请注明来源 https://blog.csdn.net/linghugoolge/article/details/84887686

一、题目

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​, followed by a line with N​C​​ coupon integers. Then the next line contains the number of products N​P​​, followed by a line with N​P​​ product values. Here 1≤N​C​​,N​P​​≤10​5​​, and it is guaranteed that all the numbers will not exceed 2​30​​.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

二、题目大意

寻找正负数最大和。

三、考点

贪心算法

四、注意

1、多使用几个数组保存,这样就不用花时间想代码了。

五、代码

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;

bool cmp(int a, int b) {
	return a > b;
}

int main() {
	//read
	int n, m;
	vector<int> v1_p, v1_n, v2_p, v2_n;
	cin >> n;
	for (int i = 0; i < n; ++i) {
		int a;
		cin >> a;
		if (a > 0)
			v1_p.push_back(a);
		else
			v1_n.push_back(a);
	}
	cin >> m;
	for (int i = 0; i < m; ++i) {
		int a;
		cin >> a;
		if (a > 0)
			v2_p.push_back(a);
		else
			v2_n.push_back(a);
	}

	//sort
	sort(v1_p.begin(), v1_p.end(), cmp);
	sort(v1_n.begin(), v1_n.end());
	sort(v2_p.begin(), v2_p.end(), cmp);
	sort(v2_n.begin(), v2_n.end());

	//solve
	int sum = 0;
	for (int i = 0; i < v1_p.size() && i < v2_p.size(); ++i) {
		sum += v1_p[i] * v2_p[i];
	}
	for (int i = 0; i < v1_n.size() && i < v2_n.size(); ++i) {
		sum += v1_n[i] * v2_n[i];
	}

	//output
	cout << sum << endl;

	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/linghugoolge/article/details/84887686