2018.07.06 POJ2536 Gopher II

Gopher II
Time Limit: 2000MS Memory Limit: 65536K
Description
The gopher family, having averted the canine threat, must face a new predator.
The are n gophers and m gopher holes, each at distinct (x, y) coordinates. A hawk arrives and if a gopher does not reach a hole in s seconds it is vulnerable to being eaten. A hole can save at most one gopher. All the gophers run at the same velocity v. The gopher family needs an escape strategy that minimizes the number of vulnerable gophers.
Input
The input contains several cases. The first line of each case contains four positive integers less than 100: n, m, s, and v. The next n lines give the coordinates of the gophers; the following m lines give the coordinates of the gopher holes. All distances are in metres; all times are in seconds; all velocities are in metres per second.
Output
Output consists of a single line for each case, giving the number of vulnerable gophers.
Sample Input
2 2 5 10
1.0 1.0
2.0 2.0
100.0 100.0
20.0 20.0
Sample Output
1
Source
Waterloo local 2001.01.27

一道二分图匹配的板子题,感觉 d i n i c 算法快的飞起,于是我写了个 d i n i c 求二分图最大匹配,其他没什么,就是建图的时候要记住判定地鼠到洞的距离是否合法就行了,还有就是多组数据记得要重置数组和 c n t

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<cmath>
#define N 300
#define M 100000
using namespace std;
struct pot{double x,y;}p[N];
int n,m,T,V,s,t,cnt,first[N],d[N];
struct edge{int v,next,c;}e[M];
inline void add(int u,int v,int c){
    e[++cnt].v=v;
    e[cnt].c=c;
    e[cnt].next=first[u];
    first[u]=cnt;
}
inline bool bfs(){
    queue<int>q;
    memset(d,-1,sizeof(d));
    d[s]=0;
    q.push(s);
    while(!q.empty()){
        int x=q.front();
        q.pop();
        for(int i=first[x];i!=-1;i=e[i].next){
            int v=e[i].v;
            if(d[v]!=-1||e[i].c<=0)continue;
            d[v]=d[x]+1;
            if(v==t)return true;
            q.push(v);
        }
    }
    return false;
}
inline int dfs(int p,int f){
    if(p==t||!f)return f;
    int flow=f;
    for(int i=first[p];i!=-1;i=e[i].next){
        int v=e[i].v;
        if(d[v]==d[p]+1&&e[i].c>0&&flow){
            int tmp=dfs(v,min(flow,e[i].c));
            if(!tmp)d[v]=-1;
            e[i].c-=tmp;
            e[i^1].c+=tmp;
            flow-=tmp;
        }
    }
    return f-flow;
}
inline double dis(pot a,pot b){return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));}
int main(){
    while(~scanf("%d%d%d%d",&n,&m,&T,&V)){
        s=0,t=n+m+1;
        int len=T*V;
        cnt=-1;
        memset(first,-1,sizeof(first));
        for(int i=1;i<=n+m;++i)scanf("%lf%lf",&p[i].x,&p[i].y);
        for(int i=1;i<=n;++i)add(s,i,1),add(i,s,0);
        for(int i=n+1;i<=n+m;++i)add(i,t,1),add(t,i,0);
        for(int i=1;i<=n;++i)
            for(int j=n+1;j<=n+m;++j)
                if(dis(p[i],p[j])<=len*1.0)add(i,j,1),add(j,i,0);
        int ans=0;
        while(bfs())ans+=dfs(s,0x3f3f3f3f);
        printf("%d\n",n-ans); 
    }
    return 0;
} 

猜你喜欢

转载自blog.csdn.net/dreaming__ldx/article/details/80939327
ii