zoj 3946 Highway Project

Edward, the emperor of the Marjar Empire, wants to build some bidirectional highways so that he can reach other cities from the capital as fast as possible. Thus, he proposed the highway project.

The Marjar Empire has N cities (including the capital), indexed from 0 to N - 1 (the capital is 0) and there are M highways can be built. Building the i-th highway costs Ci dollars. It takes Di minutes to travel between city Xi and Yi on the i-th highway.

Edward wants to find a construction plan with minimal total time needed to reach other cities from the capital, i.e. the sum of minimal time needed to travel from the capital to city i (1 ≤ i ≤ N). Among all feasible plans, Edward wants to select the plan with minimal cost. Please help him to finish this task.

Input
There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first contains two integers N, M (1 ≤ N, M ≤ 105).

Then followed by M lines, each line contains four integers Xi, Yi, Di, Ci (0 ≤ Xi, Yi < N, 0 < Di, Ci < 105).

Output
For each test case, output two integers indicating the minimal total time and the minimal cost for the highway project when the total time is minimized.

Sample Input
2
4 5
0 3 1 1
0 1 1 1
0 2 10 10
2 1 1 1
2 3 1 2
4 5
0 3 1 1
0 1 1 1
0 2 10 10
2 1 2 1
2 3 1 2
Sample Output
4 3
4 4

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int N=1e5+7,INF=0x3f3f3f3f;
struct node
{
    ll v,c,d;
};
vector<node> q[N];
bool vis[N];
ll dis[N],tim[N];
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=0; i<n; i++)
            q[i].clear(),dis[i]=1e15,tim[i]=1e15,vis[i]=false;
        for(int i=0; i<m; i++)
        {
            ll x,y;
            ll c,d;
            scanf("%lld%lld%lld%lld",&x,&y,&d,&c);
            q[x].push_back({y,c,d});
            q[y].push_back({x,c,d});
        }
        dis[0]=0;
        tim[0]=0;
        queue<int> que;
        que.push(0);
        vis[0]=true;
        while(!que.empty())
        {
            int cur=que.front();
            que.pop();
            vis[cur]=false;
            for(int i=0; i<q[cur].size(); i++)
            {
                int s=q[cur][i].v;
                ll ci=q[cur][i].c,di=q[cur][i].d;
                if(dis[s]>dis[cur]+di||(dis[s]==dis[cur]+di&&tim[s]>ci))
                {
                    dis[s]=dis[cur]+di;
                    tim[s]=ci;
                    if(!vis[s])
                    {
                        que.push(s);
                        vis[s]=true;
                    }
                }
            }
        }
        ll ans=0,ti=0;
        for(int i=0; i<n; i++)
        {
            ans+=dis[i];
            ti+=tim[i];
        }
        printf("%lld %lld\n",ans,ti);
    }
}

猜你喜欢

转载自blog.csdn.net/oinei/article/details/79840868
ZOJ
今日推荐