二分法解方程

单调函数零点可用二分法求

 基本模板

   double f(double a){}    //单调函数
  ....
  while(right-left>1e-10){
         mid=(right+left)/2;
         if(f(mid)>0)   left=mid;   //根据是递增还是递减判断
         else right=mid;  
  }

对于凹函数或凸函数的极值可用三分法求,当然也可先求导,再二分求极值点

基本模板

  double f(double a){}    //函数
  ....
  while(right-left>1e-10){
         mid=(right+left)/2;
         mmid=(mid+right)/2;
         if(f(mid)>f(mmid))   right=mid;   //根据是凹还是凸判断
         else left=mid;  
  }



题目1:hdoj2199

  

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

Input The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);Output For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.Sample Input
2
100
-4
Sample Output
1.6152
No solution!


思路分析:当函数在区间与X轴没交点时,无解


#include<iostream>
#include<cmath>
#include<stdio.h>
using namespace std;
double c;
double f(double x){
         double y;
         y=8*pow(x,4)+7*pow(x,3)+2*x*x+3*x+c;
         return y;
}
int main(){
     double y,a,b,mid;
     int t;
     cin>>t;
     while(t--){
        cin>>y;
        c=6-y;
        if(f(100)<=0||f(0)>=0) cout<<"No solution!"<<endl;
        else{
            a=0;
            b=100;
            mid=(a+b)/2;
            while(abs(b-a)>0.0000001){
                if(f(mid)>0) b=mid;
                else a=mid;
                mid=(a+b)/2;

            }
            printf("%.4f\n",mid);
        }
     }
     return 0;
}

题目2:hdoj2899

Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.

Input The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)Output Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.Sample Input
2
100
200
Sample Output
-74.4291
-178.8534

#include<iostream>
#include<cmath>
#include<stdio.h>
using namespace std;
double y;
double f1(double x){   //导函数
    double ans;
    ans=42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x-y;
    return ans;
}
double f2(double x){  //原函数
    double ans;
    ans=6*pow(x,7)+8*pow(x,6)+7*x*x*x+5*x*x-y*x;
    return ans;
}
int main(){
    double a,b,mid;
    int t;
    cin>>t;
    while(t--){
        cin>>y;
        if(f1(0)>=0) printf("%.4f\n",f2(0));
        if(f1(100)<=0) printf("%.4f\n",f2(100));
        else{
            a=0;
            b=100;
            mid=(a+b)/2;
            while(abs(b-a)>0.00000001){
                if(f1(mid)>0) b=mid;
                else a=mid;
                mid=(a+b)/2;
            }
            printf("%.4f\n",f2(a));

        }
    }
    return 0;
}






猜你喜欢

转载自blog.csdn.net/guogai13/article/details/79151966
今日推荐