bfs应用最短路径查找--三道基础题

  用BFS找最短路的基本思路为每次搜索到一个点或状态判断是否可以更新该点的最小值,若可以则放进队列中去。。。


下面这三道题目都是用BFS求最短路径的


题目1:
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input Line 1: Two space-separated integers: N and K Output Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow. Sample Input
5 17
Sample Output
4


        
  
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes. 


思路:将每次可以到的店放进队列中

#include<iostream>
#include<queue>
using namespace std;
queue<int>q;
int main(){
    int dp[200010],i,n,m,u,v,k,j;
    while(cin>>n>>m){
    for(i=0;i<=200000;i++) dp[i]=1000000;
    dp[n]=0;
    for(q.push(n);!q.empty();q.pop()){
        u=q.front();
        if(u+1<=100005&&dp[u+1]>dp[u]+1){
            dp[u+1]=dp[u]+1;
            q.push(u+1);
        }
        if(u*2<=151000&&dp[u*2]>dp[u]+1){  //注意将上界定为150000,
            dp[u*2]=dp[u]+1;
            q.push(u*2);
        }
        if(u-1>=0&&dp[u-1]>dp[u]+1){
            dp[u-1]=dp[u]+1;
            q.push(u-1);
        }
    }
    cout<<dp[m]<<endl;
    }
    return 0;
}

题目2:

Recently, Mike was very busy with studying for exams and contests. Now he is going to chill a bit by doing some sight seeing in the city.

City consists of n intersections numbered from 1 to n. Mike starts walking from his house located at the intersection number 1 and goes along some sequence of intersections. Walking from intersection number i to intersection j requires |i - j| units of energy. The total energy spent by Mike to visit a sequence of intersections p1 = 1, p2, ..., pk is equal to units of energy.

Of course, walking would be boring if there were no shortcuts. A shortcut is a special path that allows Mike walking from one intersection to another requiring only 1 unit of energy. There are exactly n shortcuts in Mike's city, the ith of them allows walking from intersection i to intersection ai (i ≤ ai ≤ ai + 1) (but not in the opposite direction), thus there is exactly one shortcut starting at each intersection. Formally, if Mike chooses a sequence p1 = 1, p2, ..., pk then for each 1 ≤ i < k satisfying pi + 1 = api and api ≠ pi Mike will spend only 1 unit of energy instead of |pi - pi + 1| walking from the intersection pi to intersection pi + 1. For example, if Mike chooses a sequence p1 = 1, p2 = ap1, p3 = ap2, ..., pk = apk - 1, he spends exactly k - 1 units of total energy walking around them.

Before going on his adventure, Mike asks you to find the minimum amount of energy required to reach each of the intersections from his home. Formally, for each 1 ≤ i ≤ n Mike is interested in finding minimum possible total energy of some sequence p1 = 1, p2, ..., pk = i.

Input

The first line contains an integer n (1 ≤ n ≤ 200 000) — the number of Mike's city intersection.

The second line contains n integers a1, a2, ..., an (i ≤ ai ≤ n , , describing shortcuts of Mike's city, allowing to walk from intersection i to intersection ai using only 1 unit of energy. Please note that the shortcuts don't allow walking in opposite directions (from ai to i).

Output

In the only line print n integers m1, m2, ..., mn, where mi denotes the least amount of total energy required to walk from intersection 1 to intersection i.

Example
Input
3
2 2 3
Output
0 1 2 
Input
5
1 2 3 4 5
Output
0 1 2 3 4 
Input
7
4 4 4 4 7 7 7
Output
0 1 2 1 2 3 3 
Note

In the first sample case desired sequences are:

1: 1; m1 = 0;

2: 1, 2; m2 = 1;

3: 1, 3; m3 = |3 - 1| = 2.

In the second sample case the sequence for any intersection 1 < i is always 1, i and mi = |1 - i|.

In the third sample case — consider the following intersection sequences:

1: 1; m1 = 0;

2: 1, 2; m2 = |2 - 1| = 1;

3: 1, 4, 3; m3 = 1 + |4 - 3| = 2;

4: 1, 4; m4 = 1;

5: 1, 4, 5; m5 = 1 + |4 - 5| = 2;

6: 1, 4, 6; m6 = 1 + |4 - 6| = 3;

7: 1, 4, 5, 7; m7 = 1 + |4 - 5| + 1 = 3.


#include<iostream>
#include<queue>
#include<string.h>
using namespace std;
queue<int>q;
int main(){
    int A[200010],dp[200010],n,u,v,i;
    cin>>n;
    for(i=1;i<=n;i++) cin>>A[i];
    memset(dp,1000000,sizeof(dp));
    dp[1]=0;
    for(q.push(1);!q.empty();q.pop()){
        u=q.front();
        v=u+1;
        if(dp[v]>dp[u]+1&&v<=n){
            dp[v]=dp[u]+1;
            q.push(v);
        }
        v=u-1;
        if(dp[v]>dp[u]+1&&v>=1){
            dp[v]=dp[u]+1;
            q.push(v);
        }
        v=A[u];
        if(dp[v]>dp[u]+1){
            dp[v]=dp[u]+1;
            q.push(v);
        }
    }
    for(i=1;i<n;i++) cout<<dp[i]<<" ";
    cout<<dp[n];
    return 0;
}



题目3:

Background
    Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him?
    The Problem
    Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.
    For people not familiar with chess, the possible knight moves are shown in Figure 1.

                                                                 
Input
    The input begins with the number n of scenarios on a single line by itself.
    Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.
Output
    For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.
Sample Input

    3
    8
    0 0
    7 0
    100
    0 0
    30 50
    10
    1 1
    1 1

Sample Output

    5
    28
    0

#include<iostream>
#include<queue>
#include<stdio.h>
#include<string.h>
using namespace std;
struct Q{
   int x,y;
};
queue<Q>q;
int main(){
    int dp[310][310],dx[]={-1,-1,1,1,-2,-2,2,2},dy[]={-2,2,-2,2,1,-1,1,-1},n,sx,sy,fx,t,fy,i;
    Q u,v,s;
    cin>>t;
    while(t--){
        scanf("%d",&n);
        scanf("%d%d%d%d",&sx,&sy,&fx,&fy);
        memset(dp,1000000,sizeof(dp));
        s.x=sx;
        s.y=sy;
        dp[sx][sy]=0;
        for(q.push(s);!q.empty();q.pop()){
            u=q.front();
            for(i=0;i<=7;i++){
                v.x=u.x+dx[i];
                v.y=u.y+dy[i];
                if(v.x>=0&&v.x<n&&v.y>=0&&v.y<n&&dp[v.x][v.y]>dp[u.x][u.y]+1){
                    dp[v.x][v.y]=dp[u.x][u.y]+1;
                    q.push(v);

                }
            }
        }
        printf("%d\n",dp[fx][fy]);

    }
    return 0;
}




猜你喜欢

转载自blog.csdn.net/guogai13/article/details/79181276