经典bfs(poj1915)

Knight Moves
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 28445   Accepted: 13373

Description

Background 
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him? 
The Problem 
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov. 
For people not familiar with chess, the possible knight moves are shown in Figure 1. 

Input

The input begins with the number n of scenarios on a single line by itself. 
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output

5
28
0

不明白为queue放在bfs里面定义是错的,定义成全局的就对了

#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
struct point
{
	int x;
	int y;
	int dis;
};
int vis[300][300];//定义标记数组 
int dx[8]={-2,-2,-1,-1,2,2,1,1};//8个前进方向 
int dy[8]={-1,1,-2,2,-1,1,-2,2};
int l;
queue<point> q;//把队列定义成全局的 
point start,end;//终点和起点 
bool ok(int x,int y)//判断能否前进 
{
	if(x>=0&&x<l&&y>=0&&y<l&&vis[x][y]==0) return true;
    return false;
}
int bfs()
{
	start.dis=0;
	q.push(start);
	vis[start.x][start.y]=1;
	point temp,next;
	while(!q.empty())
	{
		temp=q.front();
		q.pop();
		for(int i=0;i<8;i++)
		{
			next.x=temp.x+dx[i];
			next.y=temp.y+dy[i];
			if(ok(next.x,next.y))
			{
				next.dis=temp.dis+1;
				if(next.x==end.x&&next.y==end.y) return next.dis;
				q.push(next);
				vis[next.x][next.y]=1;
			}
		}
	}
}
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		cin>>l;
		memset(vis,0,sizeof(vis));
		cin>>start.x>>start.y>>end.x>>end.y;
		if(start.x==end.x&&start.y==end.y) cout<<"0"<<endl;
		else cout<<bfs()<<endl;
		while(!q.empty()) q.pop();//全局队列,每次使用完需要清空 
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/luojiushenzi/article/details/80215436