Step By Step 2873 老--质价比

老--质价比

Time Limit: 1000 ms  Memory Limit: 65536 KiB

Problem Description

给出n件物品,每件物品有质量和价格两种属性。你要做的是按质量升序排序,若质量相同则按价格降序排序。

Input

多组输入。每组先输入一个正整数n(1<=n && n <= 100),代表有n件物品。接下来的一行有n个正整数Wi(1<= Wi && Wi <= 10000),代表每件物品的质量。再接下来的一行有n个正整数Pi(1 <= Pi && Pi <= 10000),代表每件物品的价格。

Output

对于每组数据输出n行,每行两个数Wi,Pi。顺序为题目描述所要求。

Sample Input

3
1 2 2
3 2 3

Sample Output

1 3
2 3
2 2
#include<iostream>
#include<algorithm>
using namespace std;
struct thing
{
    int w;
    int p;
};
bool add (struct thing a,struct thing b)
{
    if(a.w!=b.w)
        return a.w<b.w;
    else
        return a.p>b.p;
}
int main()
{
    int n,i;
    struct thing s[101];
    while(cin>>n)
    {
        for(i=0;i<n;i++)
            cin>>s[i].w;
        for(i=0;i<n;i++)
            cin>>s[i].p;
        sort(s,s+n,add);
        for(i=0;i<n;i++)
            cout<<s[i].w<<" "<<s[i].p<<endl;
    }
    return 0;




}



猜你喜欢

转载自blog.csdn.net/wangws_sb/article/details/80872508