POJ1195(树状数组)

Mobile phones
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 20799   Accepted: 9619

Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix. 

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area. 

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table. 

The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3. 

Table size: 1 * 1 <= S * S <= 1024 * 1024 
Cell value V at any time: 0 <= V <= 32767 
Update amount: -32768 <= A <= 32767 
No of instructions in input: 3 <= U <= 60002 
Maximum number of phones in the whole table: M= 2^30 

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

Sample Input

0 4
1 1 2 3
2 0 0 2 2 
1 1 1 2
1 1 2 -1
2 1 1 2 3 
3

Sample Output

3
4

Source

IOI 2001


解题思路:二维树状数组模板题,注意一下下标和为负数的情况就行。


#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
using namespace std;
const int maxn = 1100;
int s;
long long A[maxn][maxn];
long long Tree[maxn][maxn];
int lowbit(int x) {return x&(-x);}
void add(int x, int y, long long value)
{
    if(A[x][y] + value < 0)
    {
        value = -A[x][y];
    }
    A[x][y] += value;
    for(int i = x; i <= s; i += lowbit(i))
    {
        for(int j = y; j <= s; j += lowbit(j))
        {
            Tree[i][j] += value;
        }
    }
}
long long get(int x, int y)
{
    int ans = 0;
    for(int i = x; i >= 1; i -= lowbit(i))
    {
        for(int j = y; j >= 1; j -= lowbit(j))
        {
            ans += Tree[i][j];
        }
    }
    return ans;
}
int main()
{
    int op;
    while(~scanf("%d", &op))
    {
        if(op == 3) break;
        else if(op == 0)
        {
            scanf("%d", &s);
            memset(A, 0, sizeof(A));
            memset(Tree, 0, sizeof(Tree));
        }
        else if(op == 1)
        {
            int x, y;
            long long value;
            scanf("%d%d%lld", &x, &y, &value);
            add(x + 1, y + 1, value);
        }
        else
        {
            int L, B, R, T;
            scanf("%d%d%d%d", &L, &B, &R, &T);
            long long sum = 0;
            sum += get(R + 1, T + 1);
            sum -= get(L, T + 1);
            sum -= get(R + 1, B);
            sum += get(L, B);
            printf("%lld\n", sum);
        }
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/creatorx/article/details/78194349
今日推荐