POJ - 1195 (二维树状数组)

POJ - 1195 (二维树状数组)

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix.

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area.
Input
The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table.

The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3.

Table size: 1 * 1 <= S * S <= 1024 * 1024
Cell value V at any time: 0 <= V <= 32767
Update amount: -32768 <= A <= 32767
No of instructions in input: 3 <= U <= 60002
Maximum number of phones in the whole table: M= 2^30
Output
Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.
Sample Input
0 4
1 1 2 3
2 0 0 2 2
1 1 1 2
1 1 2 -1
2 1 1 2 3
3
Sample Output
3
4

题目大意

二维点更新,区间查询。

解题思路

裸的二维树状数组
这是介绍树状数组各种操作的博客
https://blog.csdn.net/weixin_43179892/article/details/89490577

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define ll long long
const int maxn=1110;
int c[maxn][maxn];
int arr[maxn][maxn];
int n;
int lowbit(int x){
	return x&(-x);
}
//
void updata(int x,int y, int z)
{
	for(int i=x;i<=n;i+=lowbit(i))
	{
		for(int j=y;j<=n;j+=lowbit(j))
			c[i][j]+=z;
	}
}

int sum(int x,int y)//求(0,0)到 (x,y)之间的所有元素和
{
	int res=0;
	for(int i=x;i>0;i-=lowbit(i))
		for(int j=y;j>0;j-=lowbit(j))
			res+=c[i][j];
	return res;
}

int get_sum(int x1,int y1,int x2,int y2) //求左上角为(x1,y1) 右下角(x2,y2)的区间和
{
	return sum(x2,y2)-sum(x1-1,y2)-sum(x2,y1-1)+sum(x1-1,y1-1);
}

int main()
{
	int op,x,y,l,b,r,t,a;
	while(~scanf("%d",&op))
	{
		if(op==0)
		{
			scanf("%d",&n);
			memset(c,0,sizeof(c));
		}
		else if(op==1)
		{
			scanf("%d%d%d",&x,&y,&a);
			updata(x+1,y+1,a);
		}
		else if(op==2)
		{
			scanf("%d%d%d%d",&l,&b,&r,&t);
            int ans=get_sum(l+1,b+1,r+1,t+1);
            printf("%d\n",ans);
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43179892/article/details/89494106