UVA 12563 Jin Ge Jin Qu hao (背包问题之满背包)

(If you smiled when you see the title, this problem is for you ^_^)
For those who don’t know KTV, see: http://en.wikipedia.org/wiki/Karaoke_box
There is one very popular song called Jin Ge Jin Qu(). It is a mix of 37 songs, and is extremely long (11 minutes and 18 seconds) — I know that there are Jin Ge Jin Qu II and III, and some other unofficial versions. But in this problem please forget about them.
Why is it popular? Suppose you have only 15 seconds left (until your time is up), then you should select another song as soon as possible, because the KTV will not crudely stop a song before it ends (people will get frustrated if it does so!). If you select a 2-minute song, you actually get 105 extra seconds! ....and if you select Jin Ge Jin Qu, you’ll get 663 extra seconds!!! Now that you still have some time, but you’d like to make a plan now. You should stick to the following rules:
• Don’t sing a song more than once (including Jin Ge Jin Qu). • For each song of length t, either sing it for exactly t seconds, or don’t sing it at all. • When a song is finished, always immediately start a new song.
Your goal is simple: sing as many songs as possible, and leave KTV as late as possible (since we have rule 3, this also maximizes the total lengths of all songs we sing) when there are ties.
Input The first line contains the number of test cases T (T ≤ 100). Each test case begins with two positive integers n, t (1 ≤ n ≤ 50, 1 ≤ t ≤ 109), the number of candidate songs (BESIDES Jin Ge Jin Qu) and the time left (in seconds). The next line contains n positive integers, the lengths of each song, in seconds. Each length will be less than 3 minutes — I know that most songs are longer than 3 minutes. But don’t forget that we could manually “cut” the song after we feel satisfied, before the song ends. So here “length” actually means “length of the part that we want to sing”.
It is guaranteed that the sum of lengths of all songs (including Jin Ge Jin Qu) will be strictly larger than t.
Output
For each test case, print the maximum number of songs (including Jin Ge Jin Qu), and the total lengths of songs that you’ll sing.
Explanation: In the first example, the best we can do is to sing the third song (80 seconds), then Jin Ge Jin Qu for another 678 seconds. In the second example, we sing the first two (30+69=99 seconds). Then we still have one second left, so we can sing Jin Ge Jin Qu for extra 678 seconds. However, if we sing the first and third song instead (30+70=100 seconds), the time is already up (since we only have 100 seconds in total), so we can’t sing Jin Ge Jin Qu anymore!
Sample Input
2 3 100 60 70 80 3 100 30 69 70
Sample Output
Case 1: 2 758 Case 2: 3 777
#include<algorithm>
#include<iostream>
#include<string>
#include<map>//int dx[4]={0,0,-1,1};int dy[4]={-1,1,0,0};
#include<set>//int gcd(int a,int b){return b?gcd(b,a%b):a;}
#include<vector>
#include<cmath>
#include<stack>
#include<string.h>
#include<stdlib.h>
#include<cstdio>
#define maxn 10000
#define ll long long
#define INF 1000000
using namespace std;
long long song[60],n,tt;
long long dp[maxn];
int main()
{
    int t;scanf("%d",&t);
     for(int i=1;i<=t;i++)
     {
        scanf("%lld%lld",&n,&tt);
        ll sum=0;
        for(int j=1;j<=n;j++)
        {
            scanf("%lld",&song[j]);
            sum+=song[j];
        }

        printf("Case %d:",i);
        if(tt>=sum+678) { printf(" %d %d\n",n+1,sum+678) ; continue;}

        //memset(dp[0],,sizeof(dp));
//        for(int j=0;j<=n;j++)
//          for(int i=0;i<=tt;i++)
//              dp[j][i]=-INF;
//        for(int i=0;i<=n;i++) dp[i][0]=0;

        for(int i=0;i<=tt;i++) dp[i]=-INF;
        dp[0]=0;

        for(int i=1;i<=n;i++)
        {
            for(int j=tt;j>=song[i];j--)
                dp[j]=max(dp[j-song[i]]+1,dp[j]);
        }

        long long ans=0,index=0;//
        for(int i=tt-1;i>=0;i--)//
        {
            if(dp[i]>ans) { ans=dp[i];index=i; }
        }
        printf(" %lld %lld\n",ans+1,(index+678));
        //cout<<ans+1<<" "<<index+678<<endl;
     }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_37451344/article/details/80791643