【大数/高精度整数】HDOJ 1002 A+B

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 419063    Accepted Submission(s): 81324


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
 
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
 
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:   1000  1001  1004  1003  1008 

#include<stdio.h>
#include<string.h>
struct bigInteger{
	int digit[1000];//按四位一个单位保存数值
	int size;
	void init(){
		size=0;
		for(int i=0;i<1000;i++){
			digit[i]=0;
		}
	}
	void set(char str[]){
		//从字符串中提取整数
		init();
		int L=strlen(str);
		for(int i=L-1,j=0,t=0,c=1;i>=0;i--){
			t+=(str[i]-'0')*c;
			j++;
			c*=10;
			if(j==4||i==0){
				digit[size++]=t;
				j=0;
				t=0;
				c=1;
			}
		}
	}
	void output(){
		for(int i=size-1;i>=0;i--){
			if(i!=size-1){
				printf("%04d",digit[i]);
				//不是最高位的数字的话,输出补足前导0
			}else{
				printf("%d",digit[i]);
			}
		}
	}
	bigInteger operator + (const bigInteger &A)const {
		bigInteger ret;
		ret.init();
		int carry=0;//进位
		for(int i=0;i<A.size||i<size;i++){
			int tmp=A.digit[i]+digit[i]+carry;
			carry=tmp/10000;//该位的进位
			tmp%=10000;
			ret.digit[ret.size++]=tmp;
		}
		if(carry!=0){
			ret.digit[ret.size++]=carry;
		}
		return ret;
	} 
}a,b,c;
char str1[1002];
char str2[1002];
int main(){
	int n;
	scanf("%d",&n);
	for(int i=1;i<=n;i++){
		scanf("%s%s",str1,str2);
		a.set(str1);
		b.set(str2);
		c=a+b;
		printf("Case %d:\n",i);
		printf("%s + %s = ",str1,str2);
		c.output();
		if(i<n)
			printf("\n\n");
		else
			printf("\n");
	}
}

大数模板

struct bigInteger{

int digit[1000];

int size;

void init(){}

void set(){}

void output(){}

//重载运算符

};


猜你喜欢

转载自blog.csdn.net/qq_33837704/article/details/80582288