计蒜客ACM ICPC 2017 Warmup Contest 9--C题

  • 时间: 2000ms
  •  内存:65536K

A long time ago in a galaxy far, far away, there was a large interstellar trading union, consisting of many countries from all across the galaxy. Recently, one of the countries decided to leave the union. As a result, other countries are thinking about leaving too, as their participation in the union is no longer beneficial when their main trading partners are gone.

image.png

You are a concerned citizen of country X, and you want to find out whether your country will remain in the union or not. You have crafted a list of all pairs of countries that are trading partners of one another. If at least half of the trading partners of any given country leave the union, country will soon follow. Given this information, you now intend to determine whether your home country will leave the union.

Input

The input starts with one line containing four space separated integers CPX, and L. These denote the total number of countries (2 ≤ ≤ 200 000), the number of trading partnerships(1 ≤ ≤ 300000), the number of your home country (1 ≤ C) and finally the number of the first country to leave, setting in motion a chain reaction with potentially disastrous consequences (1 ≤ ≤ C).

扫描二维码关注公众号,回复: 1726339 查看本文章

This is followed by lines, each containing two space separated integers Aand Bsatisfying1 ≤ A< B≤ C. Such a line denotes a trade partnership between countries Aand Bi. No pair of countries is listed more than once.

Initially, every country has at least one trading partner in the union.

Output

For each test case, output one line containing either “leave” or “stay”, denoting whether you home country leaves or stays in the union. 

样例输入1

4 3 4 1
2 3
2 4
1 2

样例输出1

stay

样例输入2

5 5 1 1
3 4
1 2
2 3
1 3
2 5

样例输出2

leave



#include<iostream>
#include<cstring>
#include<cstdio>
#include<vector>
using namespace std;
int C,P,X,L;
int visited[200001];
vector<int>G[200001];
void f(int s)
{
	for(int i=0;i<G[s].size();i++)
	{
		int k=G[s][i];
		visited[k]--;
		if(visited[k]<=0) continue;
		if(visited[k]>G[k].size()/2) continue;
		if(visited[k]<=G[k].size()/2)
		{
			visited[k]=0;
			f(k);
		}
	}
}
int main()
{
	int m,n;
	while(scanf("%d%d%d%d",&C,&P,&X,&L)!=EOF)
	{
		memset(visited,0,sizeof(visited));
		for(int i=0;i<P;i++)
		{
			scanf("%d%d",&m,&n);
			G[m].push_back(n);
			G[n].push_back(m);
			visited[m]++;
			visited[n]++;
		}
		if(X==L)
		{
			printf("leave\n");
			continue;
		}
		visited[L]=0;
		f(L);
		if(visited[X]>0) printf("stay\n");
		else printf("leave\n");
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/zhengxiangmaomao/article/details/78308615