路由重分布(一)

实验要求:使用路由重分布让路由器学到所有路由条目

拓扑如下:

配置如下:

R1
enable
configure terminal
interface s0/0/0
ip address 192.168.4.2 255.255.255.0
no shutdown
interface s0/1/0
ip address 192.168.1.1 255.255.255.0
no shutdown
interface s0/0/1
ip address 192.168.2.1 255.255.255.0
no shutdown
exit
route rip
version 2
network 192.168.4.0
network 192.168.1.0
network 192.168.2.0
exit
ip route 192.168.7.0 255.255.255.0 192.168.4.1
router rip
redistribute static


R2
enable
configure terminal
interface s0/1/0
ip address 192.168.1.2 255.255.255.0
no shutdown
clock rate 64000
interface s0/0/1
ip address 192.168.6.2 255.255.255.0
no shutdown
clock rate 64000
interface s0/0/0
ip address 192.168.3.1 255.255.255.0
no shutdown
exit
route rip
version 2
network 192.168.1.0
network 192.168.6.0
network 192.168.3.0
exit
ip route 192.168.9.0 255.255.255.0 192.168.6.1
router rip
redistribute static

R3
enable
configure terminal
interface s0/0/0
ip address 192.168.2.2 255.255.255.0
clock rate 64000
no shutdown
interface s0/0/1
ip address 192.168.3.2 255.255.255.0
clock rate 64000
no shutdown
interface s0/1/0
ip address 192.168.5.1 255.255.255.0
clock rate 64000
no shutdown
exit
route rip
version 2
network 192.168.2.0
network 192.168.3.0
network 192.168.5.0
exit
ip route 192.168.8.0 255.255.255.0 192.168.5.2
router rip
redistribute static

R4
enable
configure terminal
interface f0/0
ip address 192.168.7.254 255.255.255.0
no shutdown
interface s0/0/0
ip address 192.168.4.1 255.255.255.0
clock rate 64000
no shutdown
exit
ip route 0.0.0.0 0.0.0.0 192.168.4.2


R5
enable
configure terminal
interface s0/0/0
ip address 192.168.6.1 255.255.255.0
no shutdown
interface f0/0
ip address 192.168.9.254 255.255.255.0
no shutdown
exit
ip route 0.0.0.0 0.0.0.0 192.168.6.2

R6
enable
configure terminal
interface s0/0/0
ip address 192.168.5.2 255.255.255.0
no shutdown
interface f0/0
ip address 192.168.8.254 255.255.255.0
no shutdown
exit
ip route 0.0.0.0 0.0.0.0 192.168.5.1

猜你喜欢

转载自www.cnblogs.com/guoshiyu/p/9214542.html