答答租车系统(面向对象综合练习)

答答租车系统(面向对象综合练习)

Time Limit: 1000 ms  Memory Limit: 65536 KiB

Problem Description

各位面向对象的小伙伴们,在学习了面向对象的核心概念——类的封装、继承、多态之后,答答租车系统开始营运了。

请你充分利用面向对象思想,为公司解决智能租车问题,根据客户选定的车型和租车天数,来计算租车费用,最大载客人数,最大载载重量。

公司现有三种车型(客车、皮卡车、货车),每种车都有名称和租金的属性;其中:客车只能载人,货车只能载货,皮卡车是客货两用车,即可以载人,也可以载货。

下面是答答租车公司的可用车型、容量及价目表:
序号     名称     载客量      载货量        租金
                           (人)     (吨)    (元/天)
  1          A            5                                 800
  2          B            5                                 400
  3          C            5                                 800
  4          D            51                             1300
  5          E            55                             1500
  6          F             5            0.45             500
  7         G             5             2.0               450
  8         H                            3                  200
  9          I                             25              1500
 10        J                             35              2000

要求:根据客户输入的所租车型的序号及天数,计算所能乘载的总人数、货物总数量及租车费用总金额。

Input

首行是一个整数:代表要不要租车 1——要租车(程序继续),0——不租车(程序结束);

第二行是一个整数,代表要租车的数量N;

接下来是N行数据,每行2个整数m和n,其中:m表示要租车的编号,n表示租用该车型的天数。

Output

若成功租车,则输出一行数据,数据间有一个空格,含义为:

载客总人数 载货总重量(保留2位小数) 租车金额(整数)

若不租车,则输出: 

0 0.00 0(含义同上)

Sample Input

1
2
1 1
2 2

Sample Output

15 0.00 1600
 
  
package hello;

import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		Car[] c = { 
				new Car(0, 5, 0, 800),
				new Car(1, 5, 0, 400), 
				new Car(2, 5, 0, 800), 
				new Car(3, 51, 0, 1300),
				new Car(4, 55, 0, 1500),
				new Car(5, 5, 0.45, 500), 
				new Car(6, 5, 2, 450), 
				new Car(7, 0, 3, 200),
				new Car(8, 0, 25, 1500),
				new Car(9, 0, 35, 2000), 
		};
		int order = cin.nextInt();
		int peopleSum = 0;
		double weightSum = 0;
		int moneySum = 0;
		if(order == 1) {
			int n = cin.nextInt();
			for (int i = 0; i < n; i++) {
				int j = cin.nextInt() - 1;
				double day = cin.nextDouble();
				moneySum += c[j].money * day;
				peopleSum += c[j].passenger * day;
				weightSum += c[j].weight * day;
			}
			System.out.println(peopleSum + " " + String.format("%.2f", weightSum) + " " + moneySum);
		}
		else 
			System.out.println(peopleSum + " " + String.format("%.2f", weightSum) + " " + moneySum);
	}
}

class Car {
	public int name, money, passenger;
	public double weight;

	
	public Car(int name, int passager, double weight, int money) {
		this.name = name;
		this.passenger = passager;
		this.weight = weight;
		this.money = money;
	}
}

 
 



猜你喜欢

转载自blog.csdn.net/horizonhui/article/details/79669495
今日推荐