HDU_1047Integer Inquiry(多个大数相加)

HDU_1047Integer Inquiry

Integer Inquiry

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23392    Accepted Submission(s): 6600


Problem Description
One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)
 

Input
The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.
 

Output
Your program should output the sum of the VeryLongIntegers given in the input.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 

Sample Input
 
  
1 123456789012345678901234567890 123456789012345678901234567890 123456789012345678901234567890 0
 

Sample Output
 
  
370370367037037036703703703670
 

Source



这一道题只要是会大数加法其实就能做出来,不过里边的坑比较多。尤其是输入0(非测试数据个数)的时候,还需要输出 0

这个坑很难发现...WA 了好多次


char s[maxn];//得到需要相加的数 
int a[maxn];//保存这个数 
int ans[maxn];//保存所有数的和 



/*
	多个大数相加 
*/

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int maxn=1e3;

char s[maxn];//得到需要相加的数 
int a[maxn];//保存这个数 
int ans[maxn];//保存所有数的和 
int main() 
{

	int n;
	scanf("%d",&n);//测试样例 
	while(n--)
	{
		int lenx=0;//最长数的长度 
		memset(ans,0,sizeof(ans));//初始化所有数的和 
		while(true)//不是 0 的话就一直循环 
		{
			memset(a,0,sizeof(a));
			scanf("%s",s);//
			int len=strlen(s);
			if(len==1&&s[0]=='0')	break;//退出循环的条件	
			lenx=max(lenx,len);
			for(int i=len-1,j=0;i>=0;i--,j++)	a[j]=s[i]-'0';
			int temp=0;
			for(int i=0;i<lenx;i++)
			{
				ans[i]=ans[i]+a[i]+temp;
				temp=ans[i]/10;				
				ans[i]%=10;				
			}
			if(temp)//进位 
			{
				ans[lenx]=temp;
				lenx++;
			}
			
		}	
		if(lenx==0)	printf("0");//emmmmmmm,这里是个坑, 
		for(int i=lenx-1;i>=0;i--)
			printf("%d",ans[i]);
		printf("\n");
		if(n)	printf("\n"); //需要多输出一行是空行 
		 
	}	
	return 0;
}





猜你喜欢

转载自blog.csdn.net/hpuer_random/article/details/80160628