Integer Inquiry

One of the first users of BIT’s new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers. “Thissupercomputerisgreat,”remarkedChip. “IonlywishTimothywereheretoseetheseresults.” (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.) Input The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative). The final input line will contain a single zero on a line by itself. Output Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890

123456789012345678901234567890

123456789012345678901234567890

0

Sample Output

370370367037037036703703703670

第一次写java ,写的大数

导入文件 用 import 

每次要导入java.util.*

要建名 为Main(大小写不能改)   的class

java 输入要写 :Scanner cin = new Scanner(System.in);

大数常数要用BigInteger定义

输入要用cin    

输出要用System.out.println();

import java.util.*;
import java.math.*;
public class Main {
	public static void main(String args[]) {
		Scanner cin = new Scanner(System.in);
		BigInteger a,ans,s;
		ans=new BigInteger("0");
		s=new BigInteger("0");
		while(cin.hasNext())
		{
			a=cin.nextBigInteger();
			if(a.equals(s))
				break;
			ans=ans.add(a);
		}		
		System.out.println(ans);
	}
}

猜你喜欢

转载自blog.csdn.net/codertcm/article/details/81176311