UVa-11400 Lighting System Design

uva 11400 Lighting System Design


问题描述

You are given the task to design a lighting system for a huge conference hall. After doing a lot of calculation and sketching, you have figured out the requirements for an energy-efficient design that can properly illuminate the entire hall. According to your design, you need lamps of n different power ratings. For some strange current regulation method, all the lamps need to be fed with the same amount of current. So, each category of lamp has a corresponding voltage rating. Now, you know the number of lamps and cost of every single unit of lamp for each category. But the problem is, you are to buy equivalent voltage sources for all the lamp categories. You can buy a single voltage source for each category (Each source is capable of supplying to infinite number of lamps of its voltage rating.) and complete the design. But the accounts section of your company soon figures out that they might be able to reduce the total system cost by eliminating some of the voltage sources and replacing the lamps of that category with higher rating lamps. Certainly you can never replace a lamp by a lower rating lamp as some portion of the hall might not be illuminated then. You are more concerned about money-saving than energy-saving. Find the minimum possible cost to design the system.

Input

Each case in the input begins with n (1 ≤ n ≤ 1000), denoting the number of categories. Each of the following n lines describes a category. A category is described by 4 integers - V (1 ≤ V ≤ 132000), the voltage rating, K (1 ≤ K ≤ 1000), the cost of a voltage source of this rating, C (1 ≤ C ≤ 10), the cost of a lamp of this rating and L (1 ≤ L ≤ 100), the number of lamps required in this category. The input terminates with a test case where n = 0. This case should not be processed.

Output

For each test case, print the minimum possible cost to design the system。

Sample Input

3
100 500 10 20
120 600 8 16
220 400 7 18
0

Sample Output

778


一道给了我DP方程我都没有想出来的题目。。。

                     d[ i ] = min ( d[ j ] + ( s[ i ] - s[ j ] ) * c[ i ] + k[ i ] , d[ j ] )

主要是没有考虑循环之前的预处理阶段。。。

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
struct lamp
{
    int v,k,c,l;
}a[1010];
int s[1010],d[1010];
bool cmp(lamp x,lamp y)               //通过v来进行排序
{
    return x.v<y.v;
}
int main()
{
    int n;
    while(cin>>n&&n)
    {
        memset(s,0,sizeof(s));
        for(int i=1;i<=n;i++)
        {
            cin>>a[i].v>>a[i].k>>a[i].c>>a[i].l;
        }
        sort(a+1,a+1+n,cmp);              
        for(int i=1;i<=n;i++)              
            s[i]=s[i-1]+a[i].l;               //用s[]数组来储存i之前的所有L的和值
        for(int i=1;i<=n;i++)
        {
            d[i]=s[i]*a[i].c+a[i].k;
            for(int j=1;j<i;j++)
                d[i]=min(d[i],d[j]+(s[i]-s[j])*a[i].c+a[i].k);   //dp公式
        }
        cout<<d[n]<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/j1nab1n9/article/details/77970458
今日推荐