hdu1074(状压dp)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1074

Doing Homework

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11457    Accepted Submission(s): 5471


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.


Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework).

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.

 

Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.


Sample Input
 
  
23Computer 3 3English 20 1Math 3 23Computer 3 3English 6 3Math 6 3
 

Sample Output
 
  
2ComputerMathEnglish3ComputerEnglishMath
Hint
In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.
 



思路:参考了https://www.cnblogs.com/kuangbin/archive/2013/04/12/3016987.html

首先用二进制表示,枚举每一个状态,第二层循环表示该状态由这本书没完成时的状态转移而来,同时记录前驱。最后输出书名的时候用一个栈(递归)即可,见代码。

#include<cstdio>
#include<algorithm>
#include<cstring>
#define INF 10000000
using namespace std;
const int maxn=16;
typedef struct
{
	char name[110];
	int dl;
	int red;
}  sub;
sub a[20];
int dp[1<<maxn];
int pre[1<<maxn];
int n;
void output(int sta)
{
	if(sta==0)
	return ;
	int t=0;
	for(int i=0;i<n;i++)
	{
		if(((1<<i)&sta)!=0 && (pre[sta]&(1<<i))==0)
		{
			t=i;
			break;
		}
	}
	output(pre[sta]);
	printf("%s\n",a[t].name);
}
int main()
{
   int t;
   scanf("%d",&t);
   while(t--)
   {
   	   scanf("%d",&n);
   	   fill(dp,dp+(1<<n),INF);
   	   dp[0]=0;
   	   memset(pre,0,sizeof(pre));
   	   for(int i=0;i<n;i++)
   	   {
   	   	  scanf("%s%d%d",a[i].name,&a[i].dl,&a[i].red);
	   }
       for(int i=0;i<(1<<n);i++)
       {
			  for(int j=0;j<n;j++)
       	   {
       	      if((1<<j)&i)
			  continue;
			  int tottime=0;
			  for(int k=0;k<n;k++)
			  {
			      if((1<<k)&i)
				  tottime+=a[k].red;	
			  }	
			  int s=tottime+a[j].red;
			  if(s>a[j].dl)
			  s-=a[j].dl;
			  else
			  s=0;
			  if(dp[i|(1<<j)]>dp[i]+s)
			  {
			     dp[i|(1<<j)]=dp[i]+s;
			     pre[i|(1<<j)]=i;
			  }
		   }
	   }
	   printf("%d\n",dp[(1<<n)-1]);
	   output((1<<n)-1);
   }
   return 0;
}


猜你喜欢

转载自blog.csdn.net/star_moon0309/article/details/80454468