NYOJ-区域赛系列一多边形划分(贪心)

区域赛系列一多边形划分


描述:
Give you a convex(凸边形), diagonal n-3 disjoint divided into n-2 triangles(直线), for different number of methods, such as n=5, there are 5 kinds of partition method, as shown in Figure
输入:
The first line of the input is a n (1<=n<=1000), expressed n data set.
The next n lines each behavior an integer m (3<=m<=18), namely the convex edges.
输出:
For each give m,, output how many classification methods.
example output: Case #a : b
样例输入
3
3
4
5
样例输出:
Case #1 : 1
Case #2 : 2

Case #3 : 5

提示:卡特兰数

程序代码:
#include<stdio.h>
int main()
{
	int m,n,i,t;
	int a[20];
	a[3]=1;
	a[4]=2;
	a[5]=5;
    for(i=5;i<18;i++)
        a[i+1]=a[i]*(4*i-6)/i;
	scanf("%d",&n);
	t=1;
	while(n--)
    {
        scanf("%d",&m); 
        printf("Case #%d : %d",t,a[m]);
		t++;    
        printf("\n");
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/HeZhiYing_/article/details/80725390