POJ 1094 Sorting It All Out【拓扑排序/BFS】

Sorting It All Out
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 38100 Accepted: 13453
Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.
Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.
Output

For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy...y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.
Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0
Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.
Source

East Central North America 2001
【题意】:
输入n和m,n表示26个字母前n个字母,m表示有多少个关系,然后输入m个关系,判断是否这n个字母存在一个排序关系,如果存在输出在几个关系之后就输出几个关系之后就可以确定,比如第一个测试数据,前四个关系输入之后,就输出结果。后两个关系输入不用管,如果存在环那么就输出冲突,如果不能确定次序就输出不能确定。
【分析】:
【代码】:

#include<cstdio>
#include<string>
#include<cstdlib>
#include<cmath>
#include<iostream>
#include<cstring>
#include<set>
#include<queue>
#include<algorithm>
#include<vector>
#include<map>
#include<cctype>
#include<stack>
#include<sstream>
#include<list>
#include<assert.h>
#include<bitset>
#include<numeric>
#define debug() puts("++++")
#define gcd(a,b) __gcd(a,b)
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define fi first
#define se second
#define pb push_back
#define sqr(x) ((x)*(x))
#define ms(a,b) memset(a,b,sizeof(a))
#define sz size()
#define be begin()
#define pu push_up
#define pd push_down
#define cl clear()
#define lowbit(x) -x&x
#define all 1,n,1
#define rep(i,n,x) for(int i=(x); i<(n); i++)
#define in freopen("in.in","r",stdin)
#define out freopen("out.out","w",stdout)
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;
typedef pair<int,int> P;
const int INF = 0x3f3f3f3f;
const LL LNF = 1e18;
const int maxn = 1e5 + 20;
const int maxm = 1e6 + 10;
const double PI = acos(-1.0);
const double eps = 1e-8;
const int dx[] = {-1,1,0,0,1,1,-1,-1};
const int dy[] = {0,0,1,-1,1,-1,1,-1};
const int mon[] = {0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
const int monn[] = {0, 31, 29, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};

int n,m,num,ok;

vector<int> G[maxn];
vector<int> ans;
queue<int> q;
char s[10];
int inDeg[maxn], tmp[maxn];

int topSort()
{
    while(!q.empty()) q.pop();
    for(int i=0;i<n;i++) ans.clear();
    ok=0;
    memcpy(tmp,inDeg,sizeof(inDeg));
    for(int i=0;i<n;i++) if(!inDeg[i]) q.push(i);
    while(!q.empty())
    {
        if(q.size()>1) ok = 1; //q中只有始终1个元素,才能保证全序
        int now = q.front();
        q.pop();
        ans.push_back(now);
        for(int i=0; i<G[now].size(); i++)
        {
            int son = G[now][i];
            if(--tmp[son] == 0) q.push(son);
        }
    }
    if(ans.size() < n) return 0; //存在环
    if(ok) return 1; //无法生成序列/不能确定次序
    return 2; //ok
}

int main()
{

    while(scanf("%d%d",&n,&m)!=EOF,n,m)
    {
        int ok=0; //必须局部定义标志变量!
        ms(inDeg,0);
        ms(tmp,0);
        for(int i=0;i<n;i++) G[i].clear();
        for(int i=0;i<n;i++) ans.clear();
        for(int i=1;i<=m;i++)
        {
            scanf("%s",s);
            if(ok) continue;
            int u = s[0] - 'A';
            int v = s[2] - 'A';
            G[u].push_back(v);
            inDeg[v]++;
            int z = topSort();
            if(z==0)
            {
                printf("Inconsistency found after %d relations.\n",i);
                ok=1;
            }
            if(z==2)
            {
                printf("Sorted sequence determined after %d relations: ",i);
                for(int i=0;i<n;i++)
                    printf("%c",ans[i]+'A');
                printf(".\n");
                ok=1;
            }
        }
        if(ok==0)
             printf("Sorted sequence cannot be determined.\n");
    }
    return 0;
}
/*
4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0
*/

猜你喜欢

转载自www.cnblogs.com/Roni-i/p/9177300.html