P2870 [USACO07DEC]最佳牛线,黄金Best Cow Line, Gold

题目描述

FJ is about to take his N (1 ≤ N ≤ 30,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

每次只能从两边取,要求取出来之后字典序最小

输入输出格式

输入格式:

 

* Line 1: A single integer: N

* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

 

输出格式:

 

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

 

输入输出样例

输入样例#1: 复制
6
A
C
D
B
C
B
输出样例#1: 复制
ABCBCD

说明

每输出80个字符需要输出一个换行。

总结:贪心 + 后缀数组

贪心应该很好想

每次在两头选择字典序最小的

如果字典序相同, 暴力就没法搞了,复杂度炸掉

考虑后缀数组比较O(nlogn)处理,O(1)比较

#include <bits/stdc++.h>
using namespace std;
const int maxn = 1e5 + 7;
int wr[maxn], y[maxn], c[maxn], rk[maxn], sa[maxn];
int p, k, ln, H[maxn], n, m; char ch[maxn];
void SA(int x) {
	m = x;
	for (int i = 1; i <= n; ++i) rk[i] = ch[i];
	for (int i = 1; i <= n; ++i) c[rk[i]]++;
	for (int i = 1; i <= m; ++i) c[i] += c[i - 1];
	for (int i = n; i >= 1; --i) sa[c[rk[i]]--] = i;
	ln = 1; p = 0;
	while(p < n) {
		k = 0;
		for (int i = n - ln + 1; i <= n; ++i) y[++k] = i;
		for (int i = 1; i <= n; ++i) if(sa[i] > ln) y[++k] = sa[i] - ln;
		memset(c, 0, sizeof c);
		for (int i = 1; i <= n; ++i) wr[i] = rk[i];
		for (int i = 1; i <= n; ++i) c[wr[y[i]]]++;
		for (int i = 1; i <= m; ++i) c[i] += c[i - 1];
		for (int i = n; i >= 1; --i) sa[c[wr[y[i]]]--] = y[i];
		for (int i = 1; i <= n; ++i) wr[i] = rk[i];
		rk[sa[1]] = 1; p = 1;
		for (int i = 2; i <= n; ++i) {
			if(!(wr[sa[i]] == wr[sa[i - 1]] && wr[sa[i] + ln] == wr[sa[i - 1] + ln])) ++p;
			rk[sa[i]] = p;
		} m = p; ln <<= 1;
	}
}
int main() {
	int pp;
	scanf("%d", &pp); 
	for (int i = 1; i <= pp; ++i) {
		char c; cin >> c;
		ch[i] = c; 
	} ch[pp + 1] = 1;
	for (int i = 1; i <= pp; ++i) ch[pp + 1 + i] = ch[pp + 1 - i];
	n = pp + pp + 1; SA(300);
	int l = 1, r = pp + 2;
	for (int i = 1; i <= n; ++i) rk[sa[i]] = i;
	for (int d = 1; d <= pp; ++d) {
		if(rk[l] < rk[r]) printf("%c", ch[l++]);
		else printf("%c", ch[r++]);
		if(d % 80 == 0) printf("\n");
	} 
	return 0;
}

  

猜你喜欢

转载自www.cnblogs.com/oi-forever/p/9174428.html