1001 A+B Format(pat甲级java)

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10
6
≤a,b≤10
6
. The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:
-1000000 9
Sample Output:
-999,991
代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB

import java.util.*;

public class Main {
    
    

  public static void main(String[] args) {
    
    
        // TODO Auto-generated method stub
        int a;
        int b;
        String sum;
        Scanner sc = new Scanner(System.in);
        a = sc.nextInt();
        b = sc.nextInt();
        sc.close();
        String s="";
        if(a+b>0) {
    
    
            sum = a + b + ""; }
        else {
    
    
        	sum=Integer.valueOf(Math.abs(a+b))+"";
        }
            int j=1;
        
        for(int i=sum.length()-1;i>=0;i--) {
    
    
        	if(j>3&&j%3==1) {
    
    
        		s=sum.charAt(i)+","+s;
        	}else {
    
    
        		s=sum.charAt(i)+s;
        	}
        	j++; }    	
       if(a+b<0) {
    
    
    	   s="-"+s;
       }
        System.out.print(s);
    }
}

猜你喜欢

转载自blog.csdn.net/qq_54537215/article/details/126992383
今日推荐