Luogu P3121 [USACO15FEB]审查(黄金)Censoring (Gold)

题目描述

Farmer John has purchased a subscription to Good Hooveskeeping magazine for his cows, so they have plenty of material to read while waiting around in the barn during milking sessions. Unfortunately, the latest issue contains a rather inappropriate article on how to cook the perfect steak, which FJ would rather his cows not see (clearly, the magazine is in need of better editorial oversight).

FJ has taken all of the text from the magazine to create the string S of length at most 10^5 characters. He has a list of censored words t_1 ... t_N that he wishes to delete from S. To do so Farmer John finds the earliest occurrence of a censored word in S (having the earliest start index) and removes that instance of the word from S. He then repeats the process again, deleting the earliest occurrence of a censored word from S, repeating until there are no more occurrences of censored words in S. Note that the deletion of one censored word might create a new occurrence of a censored word that didn't exist before.

Farmer John notes that the censored words have the property that no censored word appears as a substring of another censored word. In particular this means the censored word with earliest index in S is uniquely defined.

Please help FJ determine the final contents of S after censoring is complete.

FJ把杂志上所有的文章摘抄了下来并把它变成了一个长度不超过10^5的字符串S。他有一个包含n个单词的列表,列表里的n个单词记为t_1...t_N。他希望从S中删除这些单词。

FJ每次在S中找到最早出现的列表中的单词(最早出现指该单词的开始位置最小),然后从S中删除这个单词。他重复这个操作直到S中没有列表里的单词为止。注意删除一个单词后可能会导致S中出现另一个列表中的单词

FJ注意到列表中的单词不会出现一个单词是另一个单词子串的情况,这意味着每个列表中的单词在S中出现的开始位置是互不相同的

请帮助FJ完成这些操作并输出最后的S

输入输出格式

输入格式:

The first line will contain S.

The second line will contain N, the number of censored words. The next N lines contain the strings t_1 ... t_N. Each string will contain lower-case alphabet characters (in the range a..z), and the combined lengths of all these strings will be at most 10^5.

输出格式:

The string S after all deletions are complete. It is guaranteed that S will not become empty during the deletion process.

输入输出样例

输入样例#1: 
begintheescapexecutionatthebreakofdawn 
2 
escape 
execution 
输出样例#1: 
beginthatthebreakofdawn 

给你一个长串,许多子串,需要把长串里的所有子串删掉,并且删掉之后有可能组合出新的子串,能匹配上的都要删。问删完最后的答案。
对于新的子串的出现,我们可以维护一个栈,并且存好每个子串的长度。因为题里保证不会出现子串之间的互相包含、/多解的情况,所以我们每匹配到一串就把栈弹到top-len[i]的状态。
因为是多个子串,直接上AC自动机即可,这题是三倍经验,银和铜的都是只有一个子串,改一下输入,建一个单链的自动机,或者重新写一遍KMP即可。
代码如下:
// luogu-judger-enable-o2
// luogu-judger-enable-o2
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <iostream>
#include <queue>
#include <vector>
using namespace std;
const int N = 200000;
int ch[N][26], flg[N], fail[N], cnt=1, rt, vis[N];
int q[N], l, r;
char s1[N], t[N];
int stk[N], pos[N], top, lft[N];
int n;
class Aho_Corasick_Automaton {
public:
    void Insert(int id) {
        int  p = 1, i;
        for(i=1;t[i];i++) {
            int &ss = ch[p][t[i]-'a'];
            if(!ss) ss = ++cnt;
            p = ss;
        }
        flg[p] = id;
    }
    void Get_Fail() {
        int i,p;
        for(i=0;i<26;i++) ch[0][i]=1;
        q[r++]=1;
        while(l<r) {
            p=q[l++];
            for(i=0;i<26;i++) {
                if(ch[p][i]) fail[ch[p][i]]=ch[fail[p]][i],q[r++]=ch[p][i];
                else ch[p][i]=ch[fail[p]][i];
            }
    }
}
}AC_Automaton;
class Init_And_Solve {
private:
    void Solve() {
        //puts("Fuck3");
        int now=1;
        int len=strlen(s1+1);
        for (int i=1;i<=len;++i) {
            stk[++top]=i;
            int x=s1[i]-'a';
            int y=ch[now][x];
            if (y&&flg[y])     {
                int tmp=lft[flg[y]];
                top-=tmp;
                now=pos[stk[top]];
                continue;
            }
            pos[i]=now=y;
        }
        for(int i=1;i<=top;i++) putchar(s1[stk[i]]);
        puts("");
    }
public:
    void Init() {
        scanf("%s%d", s1+1, &n);
        for(int i=1;i<=n;i++) {
            scanf("%s", t+1);
            lft[i] = strlen(t+1);
            AC_Automaton.Insert(i);
        }
        AC_Automaton.Get_Fail();
        Solve();
    }
}IAS;
int main() {
    IAS.Init();
}

猜你喜欢

转载自www.cnblogs.com/Tobichi/p/9146000.html