数据结构实验之查找七:线性之哈希表

数据结构实验之查找七:线性之哈希表

Time Limit: 1000MS  Memory Limit: 65536KB

Problem Description

根据给定的一系列整数关键字和素数p,用除留余数法定义hash函数H(Key)=Key%p,将关键字映射到长度为p的哈希表中,用线性探测法解决冲突。重复关键字放在hash表中的同一位置。

Input

连续输入多组数据,每组输入数据第一行为两个正整数N(N <= 1000)和p(p >= N的最小素数),N是关键字总数,p是hash表长度,第2行给出N个正整数关键字,数字间以空格间隔。

Output

输出每个关键字在hash表中的位置,以空格间隔。注意最后一个数字后面不要有空格。

Example Input

5 5
21 21 21 21 21
4 5
24 15 61 88
4 5
24 39 61 15
5 5
24 39 61 15 39

Example Output

1 1 1 1 1
4 0 1 3
4 0 1 2
4 0 1 2 0

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int h[10010];

int main()
{
    int n,p;
    while(cin>>n>>p)
    {
        memset(h,-1,sizeof(h));
        while(n--)
        {
            int x,y,i=0;
            cin>>x;
            while(1)
            {
                y=(x+i)%p;
                if(h[y]==-1)
                {
                    h[y]=x;
                    break;
                }
                else if(h[y]==x)
                    break;
                else
                    i++;
            }
            if(!n)
                cout<<y<<endl;
            else
                cout<<y<<" ";
        }
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/matrix97/article/details/53572031