HDU1014

Uniform Generator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32405    Accepted Submission(s): 12915


Problem Description
Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

seed(x+1) = [seed(x) + STEP] % MOD

where '%' is the modulus operator. 

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1. 

For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations. 

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1. 

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers. 
 

Input
Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).
 

Output
For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in column 25. The "Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each output test set, your program should print exactly one blank line.
 

Sample Input
 
  
3 5 15 20 63923 99999
 

Sample Output
 
  
3 5 Good Choice 15 20 Bad Choice

63923 99999 Good Choice

这个题是个思维题,感觉;

初看样例,要是能看出样例2和样例1,3的不同;

那么猜测如果step和mod是互质的也就是gcd(steo, mod) == 1的话,那么就是Good choice;否则就不是

import java.util.*;
public class Main {
	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		while (in.hasNext()) {
			int STEP = in.nextInt();
			int MOD = in.nextInt();
			System.out.printf("%10d%10d    ", STEP, MOD);  
			if (gcd(STEP, MOD) == 1) {
				System.out.println("Good Choice");
			}
			else {
				System.out.println("Bad Choice");
			}
			System.out.println();
		}
	}
	
	public static int gcd(int a, int b) {
		if (b == 0) return a;
		else return gcd(b, a%b);
	}
}

猜你喜欢

转载自blog.csdn.net/qq_34649947/article/details/80097024
今日推荐