P142 二分搜索——最大化最小值(POJ2456 Aggressive cows)

传送门:POJ 2456

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

题意:约翰为了防止牛之间互相伤害,因此决定把每头牛都放在离其他牛尽可能远的牛舍。也就是要最大化最近的两头牛之间的距离

代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
const int maxn=1e5+10;
const int INF=1e9;
int x[maxn];
int N,M;

bool C(int d){
    int last=0;
    for(int i=1;i<M;i++){
        int crt=last+1;
        while(crt<N&&x[crt]-x[last]<d){
            crt++;
        }
        if(crt==N) return false;
        last=crt;
    }
    return true;
}

void solve(){
    //最开始时对x数组排序
    sort(x,x+N);

    //初始化解的存在范围
    int lb=0,ub=INF;

    while(ub-lb>1){
        int mid=(lb+ub)/2;
        if(C(mid)) lb=mid;
        else ub=mid;
    }
    printf("%d\n",lb);

}


int main()
{
    scanf("%d%d",&N,&M);
    for(int i=0;i<N;i++)
        scanf("%d",&x[i]);
    solve();
    return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_37275680/article/details/80541287