杭电oj1009(JAVA

                                                 FatMouse' Trade
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33703    Accepted Submission(s): 10981

Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.


Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.


Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.


Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1


Sample Output
13.333
31.500

简单贪心

import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		while(sc.hasNext()){

			double m=sc.nextInt();
			int n=sc.nextInt();
			if (m==-1&&n==-1) break;

				double j[]=new double[n];//JavaBean
				double f[]=new double[n];//猫粮

				for (int i = 0; i < f.length; i++) {
					j[i]=sc.nextDouble();
					f[i]=sc.nextDouble();
				}
			
				for (int i = 0; i < n-1; i++) {
					for (int k = i+1; k < n; k++) {
						if ((j[i]/f[i])<(j[k]/f[k])) {
						double t1=j[i]; j[i]=j[k]; j[k]=t1;
						double t2=f[i]; f[i]=f[k]; f[k]=t2;
					}					
					}    //最佳的交换次序
				}				


                double sum=0;	
				
				for (int i = 0; i < n; i++) {
					if (m>f[i]) {    //若剩余猫粮大于交换次序中所用,	
						m=m-f[i];
						sum+=j[i];	//直接得到JavaBean			
					}else{//若所剩少于交易所需
						sum+=j[i]/f[i] * m;    //求出1个单位能换得的JavaBean
							break;		        //再乘所剩的猫粮数
					}
				}

				System.out.println(String.format("%.3f", sum));
			
			}				
		}
	}

猜你喜欢

转载自blog.csdn.net/Gluskin/article/details/121237385
今日推荐