杭电oj2076(JAVA

 Problem Description

时间过的好快,一个学期就这么的过去了,xhd在傻傻的看着表,出于对数据的渴望,突然他想知道这个表的时针和分针的夹角是多少。现在xhd知道的只有时间,请你帮他算出这个夹角。
注:夹角的范围[0,180],时针和分针的转动是连续而不是离散的。

Input

输入数据的第一行是一个数据T,表示有T组数据。
每组数据有三个整数h(0 <= h < 24),m(0 <= m < 60),s(0 <= s < 60)分别表示时、分、秒。

Output

对于每组输入数据,输出夹角的大小的整数部分。

Sample Input

2 8 3 17 5 13 30

Sample Output

138 75

————————————

import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		while(sc.hasNext()) {
			int t=sc.nextInt();
			while(t-->0){

				int h=sc.nextInt();
				int m=sc.nextInt();
				int s=sc.nextInt();

				if (h>=12) {
					h-=12;
				}

				double a=h*30+m*0.5+s/120.0;	//注意精度	
				double b=m*6+s*0.1;

				double ans=Math.abs(a-b);

				if (ans>180) {
					ans=360-ans;
				}

				System.out.println((int)ans);
			}
		}
	}
}

猜你喜欢

转载自blog.csdn.net/Gluskin/article/details/121339235