杭电oj2088(JAVA

 Problem Description

Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. “Look, I've built a wall!”, he tells his older sister Alice. “Nah, you should make all stacks the same height. Then you would have a real wall.”, she retorts. After a little consideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?

Input

The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1≤n≤50 and 1≤hi≤100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.

Output

For each set, print the minimum number of bricks that have to be moved in order to make all the stacks the same height.
Output a blank line between each set.

Sample Input

6 5 2 4 1 7 5 0

Sample Output

5

———————————— 

import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		int flag=0;
		while(sc.hasNext()) {

			int n=sc.nextInt();
			if (n==0) {break;}

			if (flag!=0) {
				System.out.println();
			}

			int arr[]=new int[n];
			int sum=0;

			for (int i = 0; i < n; i++) {
				arr[i]=sc.nextInt();
				sum+=arr[i];
			}

			int sin=sum/n;
			int r=0;

			for (int i = 0; i < n; i++) {
				if (arr[i]>sin) {
					r+=arr[i]-sin;
				}
			}

			System.out.println(r);
			flag=1;
		}
	}
}

猜你喜欢

转载自blog.csdn.net/Gluskin/article/details/121341518