HDU 1520-Anniversary party(树状DP入门)

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=1520

Anniversary party

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11790    Accepted Submission(s): 4826


Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
 

Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0
 

Output
Output should contain the maximal sum of guests' ratings.
 

Sample Input
  
   
   
7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0
 

Sample Output
  
   
   
5
 
题目大意:  有n个人,每个人都有一个值val, 从中选出一些人来参加聚会,不能同时选是直接上级关系的2个职工, 求选中这些职工的val和的最大值


//树状DP入门
//通过递归计算以i为根的子树,选了第i人或者没选第i人的最大值
#include <stdio.h>
#include <vector>
#include <algorithm>
#define maxn 6005
#define inf 0x3f3f3f3f
using namespace std;

vector<int> G[maxn];
bool vis[maxn];
int val[maxn];
int dp[maxn][2];                 //dp[i][0]表示选了第i人,dp[i][1]表示没拿第i人

void dfs(int root)
{
    int l = G[root].size();
    dp[root][0] = val[root];
    for(int i=0; i<l; i++)
    	dfs(G[root][i]);
    for(int i=0; i<l; i++)
    {
    	int u = G[root][i];
    	dp[root][0] += dp[u][1];
    	dp[root][1] += max(dp[u][0], dp[u][1]);
    }
}

int main()
{
	int n;
	while(scanf("%d", &n)!=EOF)
	{
		for(int i=0; i<maxn; i++)
			{
				G[i].clear();
				vis[i] = 0;
				dp[i][0] = 0;
				dp[i][1] = 0;
			}
		for(int i=1; i<=n; i++)
		{
			scanf("%d", &val[i]);
		}
		for(;;)
		{
			int l, k;
			scanf("%d%d", &l, &k);
			if(k==0 && l==0)
				break;
			G[k].push_back(l);
			vis[l] = 1;
		}
		int ans = 0;
		for(int i=1; i<=n; i++)
			if(!vis[i])
			{
				dfs(i);
				ans += max(dp[i][0], dp[i][1]);
			}
		printf("%d\n", ans);
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_31281327/article/details/76588542