Physical Examination HDU - 4442

**Physical Examination HDU - 4442 **
WANGPENG is a freshman. He is requested to have a physical examination when entering the university.
Now WANGPENG arrives at the hospital. Er…… There are so many students, and the number is increasing!
There are many examination subjects to do, and there is a queue for every subject. The queues are getting longer as time goes by. Choosing the queue to stand is always a problem. Please help WANGPENG to determine an exam sequence, so that he can finish all the physical examination subjects as early as possible.
Input
There are several test cases. Each test case starts with a positive integer n in a line, meaning the number of subjects(queues).
Then n lines follow. The i-th line has a pair of integers (ai, bi) to describe the i-th queue:

  1. If WANGPENG follows this queue at time 0, WANGPENG has to wait for ai seconds to finish this subject.
  2. As the queue is getting longer, the waiting time will increase bi seconds every second while WANGPENG is not in the queue.
    The input ends with n = 0.
    For all test cases, 0<n≤100000, 0≤ai,bi<231.
    Output
    For each test case, output one line with an integer: the earliest time (counted by seconds) that WANGPENG can finish all exam subjects. Since WANGPENG is always confused by years, just print the seconds mod 365×24×60×60.
    Sample Input
    5
    1 2
    2 3
    3 4
    4 5
    5 6
    0
    Sample Output
    1419

Hint
In the Sample Input, WANGPENG just follow the given order. He spends 1 second in the first queue, 5 seconds in the 2th queue, 27 seconds in the 3th queue,
169 seconds in the 4th queue, and 1217 seconds in the 5th queue. So the total time is 1419s. WANGPENG has computed all possible orders in his
120-core-parallel head, and decided that this is the optimal choice.

**题解:**题意就是有n个队伍,给出a,b,a表示在0时刻排队需要花的时间,b表示在别的队伍排的时间每秒钟增加b时间,最后求排队的最小时间。
思路就是贪心,关键是按照a1*b2从小到大排序,int数据会爆,要开longlong 具体推导和代码如下:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cctype>
#include<iomanip>
#include<map>
#include<vector>
#include<list>
#include<deque>
#include<stack>
#include<queue>
#include<set>
#include<cctype>
#include<string>
#include<stdexcept>
#include<fstream>
#include<sstream>
#define mem(a,b) memset(a,b,sizeof(a))
#define debug() puts("what the fuck!")
#define dedebug() puts("what the fuck!!!")
#define ll long long
#define ull unsigned long long
#define speed {
    
    ios::sync_with_stdio(false); cin.tie(0); cout.tie(0); };
using namespace std;
const double PI = acos(-1.0);
const int maxn = 1e6 + 50;
const int N = 35;
const int INF = 0x3f3f3f3f;
const double esp_0 = 1e-6;
const int mod=365*24*60*60;
int gcd(int x, int y) {
    
    
	return y ? gcd(y, x % y) : x;
}
/**
 * 假设有两个队伍,(a1,b1),(a2,b2)
 * 先排第一队ans=a1+a1*b2+a2=a1+a2+a1*b2;
 * 先排第二队ans=a2+a2*b1+a1=a1+a2+a2*b1
 * 决定性因素是a*b
 * 所以可以对结构体进行排序
 */
struct node{
    
    
    ll a,b;
    friend bool operator<(node &x,node &y){
    
    
        return x.a*y.b<x.b*y.a;
    }
}arr[maxn];
int main(){
    
    
    int n;
    while(scanf("%d",&n),n){
    
    
        for(int i=0;i<n;++i){
    
    
            scanf("%lld %lld",&arr[i].a,&arr[i].b);
        }
        sort(arr,arr+n);
//        for(int i=0;i<n;++i)cout<<arr[i].a<<" "<<arr[i].b<<endl;
        ll ans=arr[0].a;
        for(int i=1;i<n;++i){
    
    
            ans=(ans+(ans*arr[i].b+arr[i].a))%mod;
//            cout<<ans<<"***"<<endl;
        }
        printf("%lld\n",ans);
    }
//    system("pause");
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40924271/article/details/109399488