【PAT甲级2020年秋季】7-1 Panda and PP Milk (20 分)

panda.jpg

PP milk (盆盆奶)is Pandas' favorite. They would line up to enjoy it as show in the picture. On the other hand, they could drink in peace only if they believe that the amount of PP milk is fairly distributed, that is, fatter panda can have more milk, and the ones with equal weight may have the same amount. Since they are lined up, each panda can only compare with its neighbor(s), and if it thinks this is unfair, the panda would fight with its neighbor.

Given that the minimum amount of milk a panda must drink is 200 ml. It is only when another bowl of milk is at least 100 ml more than its own that a panda can sense the difference.

Now given the weights of a line of pandas, your job is to help the breeder(饲养员)to decide the minimum total amount of milk that he/she must prepare, provided that the pandas are lined up in the given order.

Input Specification:

Each input file contains one test case. For each case, first a positive integer n (≤10​4​​) is given as the number of pandas. Then in the next line, n positive integers are given as the weights (in kg) of the pandas, each no more than 200. the numbers are separated by spaces.

Output Specification:

For each test case, print in a line the minimum total amount of milk that the breeder must prepare, to make sure that all the pandas can drink in peace.

Sample Input:

10
180 160 100 150 145 142 138 138 138 140

Sample Output:

3000

Hint:

The distribution of milk is the following:

400 300 200 500 400 300 200 200 200 300

代码:

#include<bits/stdc++.h>
using namespace std;
int main(){
    int n,milk,sum=0;
    cin>>n;
    vector<int> v(n),l(n),r(n),ans(n);
    for(int i=0;i<n;i++)
        cin>>v[i];
    //从左→右遍历
    l[0]=200;
    milk=200;
    for(int i=1;i<n;i++)
        if(v[i]>v[i-1]){
            milk+=100;
            l[i]=milk;
        }else if(v[i]==v[i-1])
            l[i]=l[i-1];
        else{
            milk=200;
            l[i]=milk;
        }
    r[n-1]=200;
    milk=200;
    //从右→左遍历
    for(int i=n-2;i>=0;i--)
        if(v[i]>v[i+1]){
            milk+=100;
            r[i]=milk;
        }else if(v[i]==v[i+1])
            r[i]=r[i+1];
        else{
            milk=200;
            r[i]=milk;
        }
      for(int i=0;i<n;i++){
          ans[i]=(l[i]>=r[i])?l[i]:r[i];
          sum+=ans[i];
      }
    printf("%d",sum);
    return 0;
}

一开始对这道题毫无思路,但是后来看到了这个方法,感觉实在是太巧妙了~

猜你喜欢

转载自blog.csdn.net/WKX_5/article/details/114704773