codeup|问题 G: 比较字符串

题目描述
输入两个字符串,比较两字符串的长度大小关系。

输入
输入第一行表示测试用例的个数m,接下来m行每行两个字符串A和B,字符串长度不超过50。

输出
输出m行。若两字符串长度相等则输出A is equal long to B;若A比B长,则输出A is longer than B;否则输出A is shorter than B。

样例输入 Copy
2
abc xy
bbb ccc
样例输出 Copy
abc is longer than xy
bbb is equal long to ccc

代码

#include<stdio.h>
#include<string.h>

int main() {
    
    
    char a[100], b[100];
    int m;
    scanf("%d",&m);
    while (m--) {
    
    
        scanf("%s %s", a, b);
        int a1 = strlen(a), b1 = strlen(b);
        if (a1 == b1) {
    
    
            printf("%s is equal long to %s\n", a, b);
        }
        else if (a1 > b1) {
    
    
            printf("%s is longer than %s\n", a, b);
        } else {
    
    
            printf("%s is shorter than %s\n", a, b);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43340821/article/details/114003926