问题 G: 比较字符串 Codeup ContestID:100000580

题目链接http://codeup.cn/problem.php?cid=100000580&pid=6

题目描述
输入两个字符串,比较两字符串的长度大小关系。

输入
输入第一行表示测试用例的个数m,接下来m行每行两个字符串A和B,字符串长度不超过50。

输出
输出m行。若两字符串长度相等则输出A is equal long to B;若A比B长,则输出A is longer than B;否则输出A is shorter than B。

样例输入
2
abc xy
bbb ccc

样例输出
abc is longer than xy
bbb is equal long to ccc

代码

#include<stdio.h>
#include<string.h>

int main() {
	int m;
	char str1[50], str2[50];
	scanf("%d", &m);
	for(int i = 0; i < m; i++) {
		scanf("%s", str1);
		scanf("%s", str2);
		int len1 = strlen(str1);
		int len2 = strlen(str2);
		if(len1 == len2)			
			printf("%s is equal long to %s\n", str1, str2);
		else if(len1 > len2)
			printf("%s is longer than %s\n", str1, str2);
		else
			printf("%s is shorter than %s\n", str1, str2);
	}
	return 0;
}
发布了97 篇原创文章 · 获赞 7 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/Rhao999/article/details/104057351