HDU 1528 Card Game Cheater(贪心)

Problem Description

Adam and Eve play a card game using a regular deck of 52 cards. The rules are simple. The players sit on opposite sides of a table, facing each other. Each player gets k cards from the deck and, after looking at them, places the cards face down in a row on the table. Adam’s cards are numbered from 1 to k from his left, and Eve’s cards are numbered 1 to k from her right (so Eve’s i:th card is opposite Adam’s i:th card). The cards are turned face up, and points are awarded as follows (for each i ∈ {1, . . . , k}):
If Adam’s i:th card beats Eve’s i:th card, then Adam gets one point.
If Eve’s i:th card beats Adam’s i:th card, then Eve gets one point.
A card with higher value always beats a card with a lower value: a three beats a two, a four beats a three and a two, etc. An ace beats every card except (possibly) another ace.
If the two i:th cards have the same value, then the suit determines who wins: hearts beats all other suits, spades beats all suits except hearts, diamond beats only clubs, and clubs does not beat any suit.
For example, the ten of spades beats the ten of diamonds but not the Jack of clubs.
This ought to be a game of chance, but lately Eve is winning most of the time, and the reason is that she has started to use marked cards. In other words, she knows which cards Adam has on the table before he turns them face up. Using this information she orders her own cards so that she gets as many points as possible.
Your task is to, given Adam’s and Eve’s cards, determine how many points Eve will get if she plays optimally.

Input

There will be several test cases. The first line of input will contain a single positive integer N giving the number of test cases. After that line follow the test cases.

Each test case starts with a line with a single positive integer k <= 26 which is the number of cards each player gets. The next line describes the k cards Adam has placed on the table, left to right. The next line describes the k cards Eve has (but she has not yet placed them on the table). A card is described by two characters, the first one being its value (2, 3, 4, 5, 6, 7, 8 ,9, T, J, Q, K, or A), and the second one being its suit (C, D, S, or H). Cards are separated by white spaces. So if Adam’s cards are the ten of clubs, the two of hearts, and the Jack of diamonds, that could be described by the line

TC 2H JD

Output

For each test case output a single line with the number of points Eve gets if she picks the optimal way to arrange her cards on the table.

Sample Input

3
1
JD
JH
2
5D TC
4C 5H
3
2H 3H 4H
2D 3D 4D

Sample Output

1
1
2

思路

将输入的数字加字母转化为数字,这样所有的牌都用数字表示大小。将两人的牌都按照从大到小的顺序排列。甲的第i张和乙的第i张比,甲大,计数加一,乙大,甲的第i+1张和乙的第i张比,直到甲大。只有甲大的时候,才用这张牌去和乙比,如果甲小,在这用这张牌就浪费了,留着去和乙较小的牌比。

代码

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;

int k;

void input(int a[])										//数据转换 
{
    
    
	char tmp[2];
		for(int i=1;i<=k;i++)
		{
    
    
			cin>>tmp;
			if(tmp[0]=='T')
				a[i]+=9*4;
			else if(tmp[0]=='J')
				a[i]+=10*4;
			else if(tmp[0]=='Q')
				a[i]+=11*4;
			else if(tmp[0]=='K')
				a[i]+=12*4;
			else if(tmp[0]=='A')
				a[i]+=13*4;
			else
			    a[i]+=int(tmp[0]-'1')*4;
			switch(tmp[1])
			{
    
    
				case 'C':a[i]+=0;break;
				case 'D':a[i]+=1;break;
				case 'S':a[i]+=2;break;
				case 'H':a[i]+=3;break;
			}
		}
}

int main()
{
    
    
	int t;
	cin>>t;
	while(t--)
	{
    
    
		cin>>k;
		int a[30]={
    
    0},b[30]={
    
    0};
		input(a);
		input(b);
		sort(a+1,a+k+1,greater<int>());					//从大到小排序 
		sort(b+1,b+k+1,greater<int>());
		int cnt=0,j=1;
		for(int i=1;i<=k;i++)
		{
    
    
			if(b[j]>a[i])
			{
    
    
				j++;
				cnt++;
			}
		}
		cout<<cnt<<endl;
	}
}

猜你喜欢

转载自blog.csdn.net/m0_54621932/article/details/113998153