007:Aggressive cows

描述Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?输入* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi输出* Line 1: One integer: the largest minimum distance样例输入

5 3
1
2
8
4
9

样例输出

3

提示OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.来源USACO 2005 February Gold

二分的关键

  • 二分的对象(一个单调的序列,问题的解包含在这个序列中)
  • 一个条件计算函数(计算结果有两种结果,可以将目标序列减半)
#include<cstdio>
#include<cmath>
#include<iostream>
#include<algorithm>
#include<vector>
#include<string>
#include<map>
#include<cstring>
#define DEBUG(x) cout << #x << " = " << x << endl
using namespace std;
const int maxn=1e5;
const int MAX=1e9;
int pos[maxn];
int N,C;
int feasible(int n)
{
    int cnt=1;
    int cur=pos[0];
    int i;
    for(i=1;i<N;i++){
        if(pos[i]>=cur+n){
            cur=pos[i];
            cnt++;
        }
    }
    int rt=cnt-C;
    return rt;
}
int bsearch(int lb,int rb)
{
    int lastPos=-1;
    int mid;
    while(lb<=rb){
        mid=(lb+rb)/2;
//        DEBUG(mid);
        if(feasible(mid)>=0){
            lastPos=mid;
            lb=mid+1;
        }
        else {
            rb=mid-1;
        }
    }
    return lastPos;
}
void printArray(int a[],int n)
{
    for(int i=0;i<n;i++){
        printf("%d ",a[i]);
    }
    printf("\n");
}
int main()
{
//    freopen("in.txt","r",stdin);
    scanf("%d %d",&N,&C);
    for(int i=0;i<N;i++){
        scanf("%d",&pos[i]);
    }
    sort(pos,pos+N);
//    printArray(pos,N);
    int Rb=MAX/C;
    int Lb=1;
    printf("%d\n",bsearch(Lb,Rb));
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/MalcolmMeng/p/9113745.html
今日推荐