Aggressive cows 愤怒的牛

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

农夫 John 建造了一座很长的畜栏,它包括N (2 <= N <= 100,000)个隔间,这些小隔间依次编号为x1,...,xN (0 <= xi <= 1,000,000,000). 但是,John的C (2 <= C <= N)头牛们并不喜欢这种布局,而且几头牛放在一个隔间里,他们就要发生争斗。为了不让牛互相伤害。John决定自己给牛分配隔间,使任意两头牛之间的最小距离尽可能的大,那么,这个最大的最小距离是什么呢

输入

* Line 1: Two space-separated integers: N and C * Lines 2..N+1: Line i+1 contains an integer stall location, xi

第一行:空格分隔的两个整数N和C

第二行---第N+1行:i+1行指出了xi的位置

输出

* Line 1: One integer: the largest minimum distance

第一行:一个整数,最大的最小值

样例输入

5 3
1
2
8
4
9

样例输出

3



(把牛放在1,4,8这样最小距离是3 )
先将栅栏排序,然后取最大间隔可能的区间0到(最远距离除牛数减1),对这个区间进行二分查找最大可行距离即可
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
const int maxn=1e5+100;
using namespace std;
int a[maxn],n,m;
bool judge(int x)//判断这个距离是否可行
{
	int l,r,t,i;
	l=1;r=1;t=1;
	while(r<=n) {
		while(r<=n&&a[l]+x>a[r]) r++;//寻找到这个间隔下的的下一个可行点
		if(r>n) break;//如果下一个可行点超出范围这结束
t++;//否则牛的数量加1 l=r;//更新当前的最远可行点 if(t==m) break;//如果牛放的下 } if(t==m) return true;//表示这个点满足 else return false; } int main() { int i,j,num,sum,mid; cin>>n>>m; sum=0; for(i=1;i<=n;i++) cin>>a[i]; sort(a+1,a+1+n);//贪心
num=a[n]/(m-1);//初始最大间隔
int l=0,r=num; while(r-l>1) { mid=(l+r)/2;//二分查找 if(judge(mid)) l=mid;//如果可行则使左边变成这个值 else r=mid;//如果值太大则是右边变成这个值
} cout<<l; return 0; }

  

猜你喜欢

转载自www.cnblogs.com/horsesea/p/9364493.html
今日推荐