多校第三场——1009 Little W and Contest

Problem Description
Given a string P consisting of only parentheses and asterisk characters (i.e. “(”, “)” and “"), you are asked to replace all the asterisk characters in order to get a balanced parenthesis string with the shortest possible length, where you can replace each "” by one “(”, or one “)”, or an empty string “”.

A parenthesis string S is a string consisting of only parentheses (i.e. “(” and “)”), and is considered balanced if and only if:

● S is an empty string, or
● there exist two balanced parenthesis strings A and B such that S=AB, or
● there exists a balanced parenthesis string C such that S=(C).

For instance, “”, “()”, “(())”, “()()”, “()(())” are balanced parenthesis strings.

Due to some notorious technical inability, if there are several solutions with the shortest possible length, then you have to report the smallest possible one in lexicographical order.

For every two different strings A and B of the same length n, we say A is smaller than B in lexicographical order if and only if there exists some integer k such that:

● 1≤k≤n, and
● the first (k−1) characters of A and that of B are exactly the same, and
● the k-th character of A is smaller than that of B.

For instance, “()(())” is smaller than “()()()”, and in this case, k=4.

Input
There are several test cases.

The first line contains an integer T (1≤T≤105), denoting the number of test cases. Then follow all the test cases.

For each test case, the only line contains a string of length n (1≤n≤105), denoting the string P that consists of only parentheses and asterisk characters.

It is guaranteed that the sum of n in all test cases is no larger than 5×106.

Output
For each test case, output in one line “No solution!” (without quotes) if no solution exists, or otherwise the smallest possible solution in lexicographical order. Note that the output characters are case-sensitive.

Sample Input
5
)))
()*
)(*


((*)()((

Sample Output
No solution!
()
()()

(())()(())

题意:给你一个字符串,里面有(、)、*三种字符,可以转化为(、)、空字符,现在让你利用给字符串里面的左右括号进行匹配,如果无法匹配,输出No solution! ,否则输出字典序最小的匹配好的字符串。

思路:字典序最小,左括号就尽量往左边放,右括号尽量往右边放。然后比较左右括号的数量,补足就行。

代码:

#include <bits/stdc++.h>
using namespace std;
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    cout.tie(0);
    int T;
    cin >> T;
    while (T--)
    {
        string s;
        cin >> s;
        int num = 0;
        int cnt = 0;
        int flag = 1;
        for (int i = 0; i < s.length(); i++)
        {
            if (s[i] == '(')
            {
                num++;
            }
            else if (s[i] == ')')
            {
                num--;
            }
            if (num < 0)
            {
                for (int j = cnt; j < i; j++)
                {
                    if (s[j] == '*')
                    {
                        s[j] = '(';
                        cnt = j + 1;
                        num++;
                        break;
                    }
                }
            }
            if (num < 0)
            {
                flag = 0;
                break;
            }
        }
        num = 0;
        cnt = s.length() - 1;
        for (int i = s.length() - 1; i >= 0; i--)
        {
            if (s[i] == ')')
            {
                num++;
            }
            else if (s[i] == '(')
            {
                num--;
            }
            if (num < 0)
            {
                for (int j = cnt; j > i; j--)
                {
                    if (s[j] == '*')
                    {
                        s[j] = ')';
                        cnt = j - 1;
                        num++;
                        break;
                    }
                }
            }
            if (num < 0)
            {
                flag = 0;
                break;
            }
        }
        if (!flag)
        {
            cout << "No solution!" << endl;
        }
        else
        {
            for (int i = 0; i < s.length(); i++)
            {
                if (s[i] != '*')
                {
                    cout<<s[i];
                }
            }
            cout << endl;
        }
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_43330910/article/details/107738645