ZOJ - 1649:Rescue

ZOJ - 1649:Rescue

来源:

标签:

参考资料:

相似题目:

题目

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.
Angel’s friends want to save Angel. Their task is: approach Angel. We assume that “approach Angel” is to get to the position where Angel stays. When there’s a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.
You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

输入

First line contains two integers stand for N and M.
Then N lines follows, every line has M characters. “.” stands for road, “a” stands for Angel, and “r” stands for Angel’s friend.
Process to the end of the file.

输出

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing “Poor ANGEL has to stay in the prison all his life.”

输入样例

7 8 
#.#####. 
#.a#..r. 
#..#x... 
..#..#.# 
#...##.. 
.#...... 
........

输出样例

13

解题思路

参考代码

#include<stdio.h>
#include<string.h>
#include<queue>
#define INF 1000000
using namespace std;

const int maxn=200+10;
char arr[maxn][maxn];
int minTime[maxn][maxn];
int dx[4]={-1,0,1,0},dy[4]={0,1,0,-1};
int n,m;
int rx,ry;//朋友的位置(rx,ry) 
int ax,ay;//天使的位置(ax,ay)

void bfs(int x,int y)
{
    queue<int> posx,posy;
    posx.push(x);
    posy.push(y);

    while(!posx.empty())
    {
        int x=posx.front(),
            y=posy.front();
        int nextTime;
        posx.pop();
        posy.pop();
        for(int i=0;i<4;i++)
        {
            int nx=x+dx[i],
                ny=y+dy[i];
            if(nx>=0 && nx<n && ny>=0 && ny<m && arr[nx][ny]!='#')
            {
                if(arr[nx][ny]=='x')nextTime=minTime[x][y]+2;
                else nextTime=minTime[x][y]+1;

                if(nextTime<minTime[nx][ny])
                {
                    minTime[nx][ny]=nextTime;
                    posx.push(nx);
                    posy.push(ny);
                }   
            }
        }
    }
}

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%s",arr[i]);
            for(int j=0;j<m;j++)
            {
                if(arr[i][j]=='a')
                {
                    ax=i;
                    ay=j;
                }
                else if(arr[i][j]=='r')
                {
                    rx=i;
                    ry=j;
                }
                minTime[i][j]=INF;
            }
        }

        minTime[rx][ry]=0;
        bfs(rx,ry);
        if(minTime[ax][ay]==INF)printf("Poor ANGEL has to stay in the prison all his life.\n");
        else printf("%d\n",minTime[ax][ay]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wingrez/article/details/80463430
ZOJ
今日推荐