C - Heavy Transportation 【kuangbin带你飞专题四】

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

题目大意:给你n个城市和m条边(双向边),求1号城市到第n号城市的道路中最大承载重量的路是多大。最大承载重量指,在这条路上最小边的值。

解题思路:用SPFA跑一遍,但是更新的时候有点不同,找路径上最小边比当前值大的,即下面代码中  if(dis[tmp.second] < min(dis[to] ,tmp.first)) 这句话

上代码    注意初始化。。。。。。别问。。。。 问就是菜

#include<iostream>
#include<vector>
#include<stack>
#include<map>
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
#include<cmath>
using namespace std;
#define ll long long
#define rep(i,n) for(ll i = 0; i < n; i++)
#define rep2(i,start,end) for(ll i = start; i < end; i++)
#define dwn(i,n) for(int i = n; i >= 0; i--)
#define dwn2(i,start,end) for(ll i = start; i >= end; i--)
#define pll pair<ll,ll>
#define mk(x,y) make_pair(x,y)
#define pdl pair<double, ll>
const ll N = 4e5 + 200;
const ll INF = 0x3f3f3f;
const ll Mode = 1e9 + 7;

ll T,n,m;
vector<pll > G[N];
ll dis[N];
ll vis[N];
ll SPFA(ll s){
	for(int i = 1; i <= n; i++){
		dis[i] = 0;
		vis[i] = 0;
	}
//	memset(vis, 0, sizeof(dis));
	dis[s] = INF;
	vis[s] = 1;
	queue<pll> q;
	q.push(mk(0,s));
	while(!q.empty()){
		pll p = q.front();
		q.pop();
		ll to = p.second;
		ll len = G[to].size();
		vis[to] = 0;
//		cout<<len<<endl;
		rep(i,len){
			pll tmp  = G[to][i];
//			cout<<tmp.first<<" "<<dis[tmp.second]<<" "<<dis[to]<<endl;
//			if(vis[tmp.second]) continue;
//			vis[tmp.second] = 1;
			if(dis[tmp.second] < min(dis[to] ,tmp.first)){
				dis[tmp.second] = min(dis[to] , tmp.first);
//				cout<<dis[tmp.second]<<endl;
				if(!vis[tmp.second]){
					q.push(mk(dis[tmp.second], tmp.second));
					vis[tmp.second] = 1;					
				}
			}
		}
	}
}
int main(){
	scanf("%lld",&T);
	rep(cas,T){
		scanf("%lld%lld",&n,&m);
		rep(i,m){
			ll x,y,z;
			scanf("%lld%lld%lld",&x,&y,&z);
			G[x].push_back({z,y});
			G[y].push_back({z,x});
		}
		SPFA(1);
		printf("Scenario #%d:\n" ,cas+1);
		printf("%lld\n\n",dis[n]);
		for(int i = 1; i <= n; i++){
			G[i].clear();
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41991981/article/details/99749282