7-6 混合类型数据格式化输入 (5 分)

本题要求编写程序,顺序读入浮点数1、整数、字符、浮点数2,再按照字符、整数、浮点数1、浮点数2的顺序输出。

输入格式:

输入在一行中顺序给出浮点数1、整数、字符、浮点数2,其间以1个空格分隔。

输出格式:

在一行中按照字符、整数、浮点数1、浮点数2的顺序输出,其中浮点数保留小数点后2位。

输入样例:

2.12 88 c 4.7

输出样例:

c 88 2.12 4.70

C++实现如下:

#include <iostream>
#include <stdio.h>
using namespace std;

int main()
{
    int b;
    float a,d;
    char c;
    cin >>a>>b>>c>>d;
    printf("%c %d %.2f %.2f\n",c,b,a,d);
    return 0;
}
原创文章 84 获赞 34 访问量 6万+

猜你喜欢

转载自blog.csdn.net/qq_42194332/article/details/98481165
今日推荐