1002 A+B for Polynomials (Python实现)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

Python实现:

dic = {}
for i in range(2):
    x = input().split()
    for j in range(1, len(x)):
        if j % 2 == 1:
            try:
                dic[int(x[j])] += float(x[j + 1])
            except KeyError:
                dic[int(x[j])] = float(x[j + 1])
dic1 = sorted(dic.items(), key=lambda z: z[0], reverse=True)
list1 = []
for i in range(len(dic)):
    if dic1[i][1] != 0:
        list1.append(str(dic1[i][0]))
        list1.append(str(round(dic1[i][1], 1)))
if len(list1) == 0:
    print("0")
else:
    print(int(len(list1) / 2), end=" ")
    print(" ".join(list1))
# 需要注意:
# 1.系数为0的情况需要过滤
# 2.结果为0时不能带空格
发布了79 篇原创文章 · 获赞 100 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/lee1hong/article/details/103336216