PTA数据结构起步能力自测题-4:Have Fun with Numbers

题目要求

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

题目翻译(仅供参考)

代码

#include <bits/stdc++.h>
using namespace std;
struct data{
    char str[20];
    int index[10]={0};
};
typedef struct data Data;
void doubleNum(Data data1,Data data2,int len)
{
    int i;
    bool flag=true;
    for(i=len-1;i>=0;i--){
        int temp=(data1.str[i]-48);
        data1.index[temp]++;
        temp*=2;
        if(temp>=10){
            temp-=10;
        }
        if(i!=len-1){
            if((data1.str[i+1]-48)*2>=10)
                temp++;
        }
        data2.str[i]=(char)temp+48;
        data2.index[temp]++;
    }
    for(i=0;i<10;i++){
        if(data1.index[i]!=data2.index[i]){
            flag=false;
            break;
        }
    }
    if(flag==true){
        cout<<"Yes"<<endl;
    }
    else{
        cout<<"No"<<endl;
        if((data1.str[0]-48)>4)
            cout<<"1";
    }
        for(i=0;i<len;i++){
            cout<<data2.str[i];
        }
        cout<<endl;
}
int main()
{
    int len;
    Data data1,data2;
    cin>>data1.str;
    len=strlen(data1.str);
    doubleNum(data1,data2,len);
    return 0;
}

提交结果

发布了16 篇原创文章 · 获赞 0 · 访问量 355

猜你喜欢

转载自blog.csdn.net/x568059888/article/details/104850512