PTA 自测-4 Have Fun with Numbers

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:
Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:
For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798


坑:因为这是英文题,一串数字乘以2后,还是那串数字,只是位置不同,就打Yes和结果,否则就打No和结果

n =input()

if sorted(n) == sorted(str(int(n)*2)):
    print("Yes")
    print(int(n)*2)

else:
    print("No")
    print(int(n)*2)

猜你喜欢

转载自blog.csdn.net/byakki/article/details/87903519