hoj2143 Songs 贪心

Description
John Doe is a famous DJ and, therefore, has the problem of optimizing the placement of songs on his tapes. For a given tape and for each song on that tape John knows the length of the song and the frequency of playing that song. His problem is to record the songs on the tape in an order that minimizes the expected access time. If the songs are recorded in the order Ss(1), …, Ss(n) on the tape then the function that must be minimized is

ni=1f(s(i))ij=1l(s(j))
where fs(i) is the frequency of playing the ith song and l is the length of the song. Can you help John?

The program input is from standard input. Each data set in the input stands for a particular set of songs that must be recorded on a tape. A data set starts with the number N (fits a 16 bit integer) of songs. Follow N the song specifications, and in the end, a number representing the position of a song S on the optimized tape. A song specification consists of the song identifier (fits an integer), the length of the song (fits a 16 bit integer), and the frequency of playing the song (a floating-point number). The program prints the identifier of the song S.

White spaces can occur freely in the input. The input data are correct and terminate with an end of file. For each set of data the program prints the result to the standard output from the beginning of a line. An input/output sample is given below. There is a single data set that contains 5 song specifications. The first song has the identifier 1, length 10 and playing frequency 45.5 etc. The result for the data set is the identifier of the 3rd song on the optimized tape. It is 2 for the given example.

Input
Output
Sample Input
5
1 10 45.5
2 5 20
30 20 10
400 50 35
15 17 89.9
3
Sample Output
2
题意:(考试时题意废,读了好久QAQ
给你一份歌单,每首歌都有各自的序号、时长(l)和被演奏的频率(f),要让歌单上面的所有歌都演奏完,且保证所需时间最少,问第k个演奏的歌曲序号是多少。
题解:考虑相邻的两首歌是否交换。

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <stack>
#define N 100005
using namespace std;
struct A{
    int id,len;
    double fre;
}a[N];
bool cmp(A i,A j){
    return (double) (j.fre * i.len) < (double) (i.fre * j.len);
}
int T,n,m;
int main(){
    while(~scanf("%d", &n)){
        for(int i = 1; i <= n; i++)
            scanf("%d%d%lf", &a[i].id, &a[i].len, &a[i].fre);
        sort(a + 1, a + 1 + n, cmp);
        scanf("%d", &m);
        printf("%d\n", a[m].id);
    }
    return 0;
}
发布了87 篇原创文章 · 获赞 7 · 访问量 3万+

猜你喜欢

转载自blog.csdn.net/yxr0105/article/details/78864377