贪心 || 贪心+并查集

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σ x∈Sellpx. An optimal selling schedule is a schedule with a maximum profit. 
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80. 


Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products. 

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10

Sample Output

80
185

Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

扫描二维码关注公众号,回复: 5299970 查看本文章

给你一组数,分别代表它的价值和使用它的截止时间,求能得到的最大价值

先按照价值排序,然后枚举时间,从截止时间向前枚举,如果这个时间节点可用就放上。

#include<string.h>
#include<stdio.h>
#include<malloc.h>
#include<iostream>
#include<algorithm>
using namespace std;
int n;
struct fun
{
    int d;
    int v;
}arr[10006];
bool cmp(const fun &a,const fun &b)
{
    return a.v>b.v;
}
int vis[10006];
int main()
{
    while(cin>>n)
    {
        memset(vis,0,sizeof(vis));
        for(int i=1;i<=n;i++){
            cin>>arr[i].v>>arr[i].d;
        }
        sort(arr+1,arr+n+1,cmp);
        int t=0;
        int s=0;
        for(int i=1;i<=n;i++){
                for(int j=arr[i].d;j>=1;j--){
                    if(!vis[j]){
                        s+=arr[i].v;
                        vis[j]=1;
                        break;
                    }
                }
        }
        cout<<s<<endl;
    }
}

猜你喜欢

转载自blog.csdn.net/lanshan1111/article/details/87809015