poj1837 Balance 看似dfs但是是枚举(dp)

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
It is guaranteed that will exist at least one solution for each test case at the evaluation. 

Input

The input has the following structure: 
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm); 
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values. 

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2
 
 
题解网上都有,但是,我想说的是思考过程。这种类型的题目应该很清楚,没有简单的办法,只有穷举每一种状态,于是很自然的想到了dfs,但是复杂度确实20^20,在模拟的时候,会发现有很多状态是重复的,有一种意识想去压缩状态,记录状态,但是不知道如何具体去做,我的想法是用一个结构体,记录每一个状态的左边和右边还有方法数,但是没敢下手...
 
 
 
 
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int f[21][15001]={0};
int main()
{
	int n,g,c[21],w[21],i,j,k;
	cin>>n>>g;
	for(i=1;i<=n;i++)cin>>c[i];
	for(i=1;i<=g;i++)cin>>w[i];
	f[0][7500]=1;
	for(i=1;i<=g;i++)
	   for(j=0;j<=15000;j++)
	     if(f[i-1][j])
	       for(k=1;k<=n;k++)
	          f[i][j+w[i]*c[k]]+=f[i-1][j];
	cout<<f[g][7500]<<endl;
}


猜你喜欢

转载自blog.csdn.net/yslcl12345/article/details/50774992