HDU - 2041 超级楼梯 【递推】

Description

有一楼梯共M级,刚开始时你在第一级,若每次只能跨上一级或二级,要走上第M级,共有多少种走法?

Input

输入数据首先包含一个整数N,表示测试实例的个数,然后是N行数据,每行包含一个整数M(1<=M<=40),表示楼梯的级数。

Output

对于每个测试实例,请输出不同走法的数量

Sample Input

2
2
3

Sample Output

1
2
#include <iostream>
#include <cstdio>

using namespace std;

int a[50];

int main() {
    int n,m;

    a[1] = 1;
    a[2] = 2;
    for(int i = 3; i <= 42; i++)
        a[i] = a[i-1] + a[i-2];

    scanf("%d", &n);

    while(n--) {
        scanf("%d",&m);
        printf("%d\n", a[m-1]);
    }
    return 0;
}
发布了329 篇原创文章 · 获赞 342 · 访问量 17万+

猜你喜欢

转载自blog.csdn.net/Aibiabcheng/article/details/105321392