USACO-Section 3.1-PROB Contact

Contact
IOI'98

The cows have developed a new interest in scanning the universe outside their farm with radiotelescopes. Recently, they noticed a very curious microwave pulsing emission sent right from the centre of the galaxy. They wish to know if the emission is transmitted by some extraterrestrial form of intelligent life or if it is nothing but the usual heartbeat of the stars.

Help the cows to find the Truth by providing a tool to analyze bit patterns in the files they record. They are seeking bit patterns of length A through Binclusive (1 <= A <= B <= 12) that repeat themselves most often in each day's data file. They are looking for the patterns that repeat themselves most often. An input limit tells how many of the most frequent patterns to output.

Pattern occurrences may overlap, and only patterns that occur at least once are taken into account.

PROGRAM NAME: contact

INPUT FORMAT

Line 1: Three space-separated integers: A, B, N; (1 <= N ≤ 50)
Lines 2 and beyond: A sequence of as many as 200,000 characters, all 0 or 1; the characters are presented 80 per line, except potentially the last line.

SAMPLE INPUT (file contact.in)

2 4 10
01010010010001000111101100001010011001111000010010011110010000000

In this example, pattern 100 occurs 12 times, and pattern 1000 occurs 5 times. The most frequent pattern is 00, with 23 occurrences.

OUTPUT FORMAT

Lines that list the N highest frequencies (in descending order of frequency) along with the patterns that occur in those frequencies. Order those patterns by shortest-to-longest and increasing binary number for those of the same frequency. If fewer than N highest frequencies are available, print only those that are.

Print the frequency alone by itself on a line. Then print the actual patterns space separated, six to a line (unless fewer than six remain).

SAMPLE OUTPUT (file contact.out)

23
00
15
01 10
12
100
11
11 000 001
10
010
8
0100
7
0010 1001
6
111 0000
5
011 110 1000
4
0001 0011 1100

主要是用map存下每一个子串出现的次数
再开一个结构体方便进行比较
注意输入输出的特殊要求(调了半天)
string.assign函数好用 (s2.assign(s1,i,j)表示把s1中i开始的j位赋给s2

#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
#include<map>
#define name "contact"
using namespace std;
map <string,int> cnt;
map <string,bool> have;
int a,b,n,len;
string s,str1;
struct save_
{
	int num,times;
	string ss;
}save[100000];
int st;
int change(string x)
{
	int ret=0,tmp=1;
	for (int i=x.length()-1;i>=0;i--)
	{
		ret+=(x[i]-'0')*tmp;
		tmp*=2;
	}
	return ret;
}
bool cmp(save_ x,save_ y)
{
	if (x.times!=y.times) return x.times>y.times;
	else if (x.ss.length()!=y.ss.length()) return y.ss.length()>x.ss.length();
	     else return x.num<y.num;
}
int main()
{
	freopen(name ".in","r",stdin);
	freopen(name ".out","w",stdout);
	cin>>a>>b>>n;int i,j;
	string line;
	while (cin>>line)
	s+=line;
	len=s.length();
	for (i=a;i<=b;i++)
	{
		for (j=0;j<=len-1-(i-1);j++)
		{
			str1.assign(s,j,i);
			cnt[str1]++;
		}
	}
	for (i=a;i<=b;i++)
	  for (j=0;j<=len-1-(i-1);j++)
	  {
	      str1.assign(s,j,i);
	      if (have[str1]==0)
	      {
	      	  st++;
	      	  save[st].ss=str1;
	      	  save[st].times=cnt[str1];
	      	  save[st].num=change(str1);//转为十进制 
	      	  have[str1]=1;
	      }
	  }
	sort(save+1,save+1+st,cmp);
	int tmp=1,hehe=0;
	for (i=1;i<=n;i++)
	{
		if (save[tmp].times==0) break;
		cout<<save[tmp].times<<endl;
		cout<<save[tmp].ss;hehe++;
		while (save[tmp].times==save[tmp+1].times)
		{
			if (hehe==0) cout<<save[tmp+1].ss;
		    else cout<<" "<<save[tmp+1].ss;
			tmp++;
			hehe++;
			if(hehe==6) cout<<endl,hehe=0;
	    }
		tmp++;
		if (hehe!=0) cout<<endl; 
		hehe=0;
	}
	return 0;
}



发布了20 篇原创文章 · 获赞 0 · 访问量 5208

猜你喜欢

转载自blog.csdn.net/SoYouTry/article/details/50574780